jquery (npm)
Advisories
12
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 3.5.0 or later clears every advisory below that has a fix.
Upgrade commands
npm
npm install jquery@3.5.0yarn
yarn add jquery@3.5.0pnpm
pnpm add jquery@3.5.0Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-257q-pv89-v3xv Duplicate Advisory: jQuery Cross Site Scripting vulnerability Withdrawn |
Medium | >= 1.0.3, < 3.5.0 | 3.5.0 |
| GHSA-579v-mp3v-rrw5 jQuery vulnerable to Cross-Site Scripting (XSS) |
Medium EPSS 19.19% |
< 1.6.3 | 1.6.3 |
| GHSA-2pqj-h3vj-pqgw Cross-Site Scripting in jquery |
Medium EPSS 8.63% |
< 1.9.0 | 1.9.0 |
| GHSA-q4m3-2j7h-f7xw Cross-Site Scripting in jquery |
Medium EPSS 6.43% |
>= 1.2.1, < 1.9.0 | 1.9.0 |
| GHSA-gxr4-xjj5-5px2 Potential XSS vulnerability in jQuery |
Medium EPSS 99.22% |
>= 1.12.0, < 3.5.0 | 3.5.0 |
| CVE-2020-11023 Potential XSS vulnerability in jQuery Known exploited |
Medium EPSS 84.89% |
>= 1.0.3, < 3.5.0 | 3.5.0 |
| CVE-2020-11023 Potential XSS vulnerability in jQuery Known exploited |
Medium EPSS 84.89% |
>= 1.0.3, < 3.5.0 | 3.5.0 |
| GHSA-wv67-q8rr-grjp Duplicate Advisory: Prototype Pollution in jquery Withdrawn |
Medium | < 3.4.0 | 3.4.0 |
| DRUPAL-CORE-2019-006 XSS in jQuery as used in Drupal, Backdrop CMS, and other products |
Medium EPSS 86.82% |
>= 1.1.4, < 3.4.0 | 3.4.0 |
| GHSA-mhpp-875w-9cpv Denial of Service in jquery |
High EPSS 3.23% |
>= 3.0.0-rc.1, < 3.0.0 | 3.0.0 |
| GHSA-rmxg-73gg-4p98 Cross-Site Scripting (XSS) in jquery |
Medium EPSS 29.73% |
< 1.12.2 | 1.12.2 |
| GHSA-rmxg-73gg-4p98 Cross-Site Scripting (XSS) in jquery |
Medium EPSS 29.73% |
>= 1.12.3, < 3.0.0 | 3.0.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor