GHSA-mhpp-875w-9cpv CVE-2016-10707
Denial of Service in jquery
- Severity
- 7.5 / 10
- High · CVSS 3.0
- Exploit chance (EPSS)
- 3.23%
- Chance of exploitation in the next 30 days. Higher than 88.26% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Fix
- Available
- 4 packages have a fixed version
Description
Affected versions of jquery use a lowercasing logic on attribute names. When given a boolean attribute with a name that contains uppercase characters, jquery enters into an infinite recursion loop, exceeding the call stack limit, and resulting in a denial of service condition.
Recommendation
Update to version 3.0.0 or later.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.webjars.npm:jquery | >= 3.0.0-rc1, < 3.0.0 |
3.0.0 |
NuGet
| Package | Vulnerable | Fixed in |
|---|---|---|
| jQuery | >= 3.0.0-rc.1, < 3.0.0 |
3.0.0 |
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| jquery-rails | >= 3.0.0-rc.1, < 3.0.0 |
3.0.0 |
npm
| Package | Vulnerable | Fixed in |
|---|---|---|
| jquery | >= 3.0.0-rc.1, < 3.0.0 |
3.0.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.webjars.npm:jquery Maven → 3.0.0
- maven
<dependency><groupId>org.webjars.npm</groupId><artifactId>jquery</artifactId><version>3.0.0</version></dependency>- gradle
implementation("org.webjars.npm:jquery:3.0.0")
jQuery NuGet → 3.0.0
- dotnet
dotnet add package jQuery --version 3.0.0
jquery-rails RubyGems → 3.0.0
- bundler
bundle update jquery-rails # Gemfile: gem "jquery-rails", ">= 3.0.0"
jquery npm → 3.0.0
- npm
npm install jquery@3.0.0- yarn
yarn add jquery@3.0.0- pnpm
pnpm add jquery@3.0.0
Severity breakdown
CVSS 3.0 7.5
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-400: Uncontrolled Resource Consumption
The product does not properly control the allocation and maintenance of a limited resource.
How to prevent it
- Architecture and Design: Design throttling mechanisms into the system architecture. The best protection is to limit the amount of resources that an unauthorized user can cause to be expended. A strong authentication and access control model will help prevent such attacks from occurring in the first place. The login application should be protected against DoS attacks as much as possible. Limiting the database access, perhaps by caching result sets, can help minimize the resources expended. To further limit the potential for a DoS attack, consider tracking the rate of requests received from users and blocking requests that exceed a defined rate threshold.
- Architecture and Design: Mitigation of resource exhaustion attacks requires that the target system either: recognizes the attack and denies that user further access for a given amount of time, or uniformly throttles all requests in order to make it more difficult to consume resources more quickly than they can again be freed. The first of these solutions is an issue in itself though, since it may allow attackers to prevent the use of the system by a particular valid user. If the attacker impersonates the valid user, they may be able to prevent the user from accessing the server in question. The second solution is simply difficult to effectively institute -- and even when properly done, it does not provide a full solution. It simply makes the attack require more resources on the part of the attacker.
- Architecture and Design: Ensure that protocols have specific limits of scale placed on them.
- Implementation: Ensure that all failures in resource allocation place the system into a safe posture.
CWE-674: Uncontrolled Recursion
The product does not properly control the amount of recursion that takes place, consuming excessive resources, such as allocated memory or the program stack.
How to prevent it
- Implementation: Ensure that an end condition will be reached under all logic conditions. The end condition may include checking against the depth of recursion and exiting with an error if the recursion goes too deep. The complexity of the end condition contributes to the effectiveness of this action.
- Implementation: Increase the stack size.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| CVE-2020-11023 Potential XSS vulnerability in jQuery | Medium Known exploited | Also affects jquery |
| GHSA-579v-mp3v-rrw5 jQuery vulnerable to Cross-Site Scripting (XSS) | Medium | Also affects jquery |
| GHSA-2pqj-h3vj-pqgw Cross-Site Scripting in jquery | Medium | Also affects jquery |
| GHSA-q4m3-2j7h-f7xw Cross-Site Scripting in jquery | Medium | Also affects jquery |
| GHSA-gxr4-xjj5-5px2 Potential XSS vulnerability in jQuery | Medium | Also affects jquery |
| DRUPAL-CORE-2019-006 XSS in jQuery as used in Drupal, Backdrop CMS, and other products | Medium | Also affects jquery |
| GHSA-rmxg-73gg-4p98 Cross-Site Scripting (XSS) in jquery | Medium | Also affects jquery |
| GHSA-4whc-pp4x-9pf3 jquery-rails and jquery-ujs subject to Exposure of Sensitive Information | Medium | Also affects jquery-rails |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor