@apollo/gateway (npm)
Advisories
1
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.8.5 or later clears every advisory below that has a fix.
Upgrade commands
npm
npm install @apollo/gateway@2.8.5yarn
yarn add @apollo/gateway@2.8.5pnpm
pnpm add @apollo/gateway@2.8.5Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-fmj9-77q8-g6c4 Apollo Query Planner and Apollo Gateway may infinitely loop on sufficiently complex queries |
High EPSS 0.99% |
>= 2.0.0, < 2.8.5 | 2.8.5 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor