Skip to content

Tauri (crates.io)

Advisories
16
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 2.11.1 or later clears every advisory below that has a fix.

Upgrade commands
cargo
cargo update -p Tauri --precise 2.11.1

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-7gmj-67g7-phm9
Tauri has an Origin Confusion Issue that Allows Remote Pages to Invoke Local-Only IPC Commands
High
EPSS 0.31%
>= 2.0.0, < 2.11.1
2.11.1
GHSA-57fm-592m-34r7
iFrames Bypass Origin Checks for Tauri API Access Control
Medium
EPSS 0.35%
>= 2.0.0-beta.0, < 2.0.0-beta.20
2.0.0-beta.20
GHSA-57fm-592m-34r7
iFrames Bypass Origin Checks for Tauri API Access Control
Medium
EPSS 0.35%
< 1.6.7
1.6.7
GHSA-wmff-grcw-jcfm
Tauri vulnerable to Regression on Filesystem Scope Checks for Dotfiles
Critical
EPSS 0.65%
>= 1.4.0, < 1.4.1
1.4.1
GHSA-4wm2-cwcf-wwvp
Tauri Open Redirect Vulnerability Possibly Exposes IPC to External Sites
Medium
EPSS 0.52%
>= 1.0.0, < 1.0.9
1.0.9
GHSA-4wm2-cwcf-wwvp
Tauri Open Redirect Vulnerability Possibly Exposes IPC to External Sites
Medium
EPSS 0.52%
>= 1.2.0, < 1.2.5
1.2.5
GHSA-4wm2-cwcf-wwvp
Tauri Open Redirect Vulnerability Possibly Exposes IPC to External Sites
Medium
EPSS 0.52%
>= 1.1.0, < 1.1.4
1.1.4
GHSA-6mv3-wm7j-h4w5
Tauri Filesystem Scope Glob Pattern is too Permissive
High
EPSS 1.07%
>= 2.0.0-alpha.0, < 2.0.0-alpha.2
2.0.0-alpha.2
GHSA-6mv3-wm7j-h4w5
Tauri Filesystem Scope Glob Pattern is too Permissive
High
EPSS 1.07%
>= 1.0.0, < 1.0.8
1.0.8
GHSA-6mv3-wm7j-h4w5
Tauri Filesystem Scope Glob Pattern is too Permissive
High
EPSS 1.07%
>= 1.1.0, < 1.1.3
1.1.3
GHSA-6mv3-wm7j-h4w5
Tauri Filesystem Scope Glob Pattern is too Permissive
High
EPSS 1.07%
>= 1.2.0, < 1.2.3
1.2.3
GHSA-q9wv-22m9-vhqh
Tauri Filesystem Scope can be Partially Bypassed
Medium
EPSS 0.46%
>= 1.0.0, < 1.0.7
>= 1.1.0, < 1.1.2
1.0.7
1.1.2
GHSA-q9wv-22m9-vhqh
Tauri Filesystem Scope can be Partially Bypassed
Medium
EPSS 0.46%
>= 1.1.0, < 1.1.2
1.1.2
GHSA-q9wv-22m9-vhqh
Tauri Filesystem Scope can be Partially Bypassed
Medium
EPSS 0.46%
>= 1.0.0, < 1.0.7
1.0.7
GHSA-28m8-9j7v-x499
Tauri's readDir Endpoint Scope can be Bypassed With Symbolic Links
Medium
EPSS 1.02%
< 1.0.6
1.0.6
GHSA-28m8-9j7v-x499
Tauri's readDir Endpoint Scope can be Bypassed With Symbolic Links
Medium
EPSS 1.02%
>= 0.0.0-0, < 1.0.6
1.0.6
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor