sequoia-openpgp (crates.io)
Advisories
12
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.1.0 or later clears every advisory below that has a fix.
Upgrade commands
cargo
cargo update -p sequoia-openpgp --precise 2.1.0Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-v6x3-9r38-r27q Sequoia PGP has Subtraction Overflow when aes_key_unwrap function is provided ciphertext that is too short |
Medium EPSS 0.35% |
< 2.1.0 | 2.1.0 |
| GHSA-v6x3-9r38-r27q Sequoia PGP has Subtraction Overflow when aes_key_unwrap function is provided ciphertext that is too short |
Medium EPSS 0.35% |
>= 0.0.0-0, < 2.1.0 | 2.1.0 |
| GHSA-rfx3-ffrp-6875 Duplicate Advisory: sequoia-openpgp vulnerable to out-of-bounds array access leading to panic Withdrawn |
Low | >= 1.9.0, < 1.16.0 | 1.16.0 |
| GHSA-rfx3-ffrp-6875 Duplicate Advisory: sequoia-openpgp vulnerable to out-of-bounds array access leading to panic Withdrawn |
Low | < 1.1.1 | 1.1.1 |
| GHSA-rfx3-ffrp-6875 Duplicate Advisory: sequoia-openpgp vulnerable to out-of-bounds array access leading to panic Withdrawn |
Low | >= 1.2.0, < 1.8.1 | 1.8.1 |
| GHSA-g97w-mw7g-v3jv Duplicate Advisory: Low severity (DoS) vulnerability in sequoia-openpgp Withdrawn |
Low | >= 1.13.0, < 1.21.0 | 1.21.0 |
| GHSA-9344-p847-qm5c Low severity (DoS) vulnerability in sequoia-openpgp |
High EPSS 0.43% |
>= 1.13.0, < 1.21.0 | 1.21.0 |
| GHSA-9344-p847-qm5c Low severity (DoS) vulnerability in sequoia-openpgp |
High EPSS 0.43% |
>= 1.13.0, < 1.21.0 | 1.21.0 |
| GHSA-25mx-8f3v-8wh7 sequoia-openpgp vulnerable to out-of-bounds array access leading to panic |
Medium EPSS 0.33% |
< 1.1.1 | 1.1.1 |
| GHSA-25mx-8f3v-8wh7 sequoia-openpgp vulnerable to out-of-bounds array access leading to panic |
Medium EPSS 0.33% |
>= 0.0.0-0, < 1.1.1>= 1.2.0, < 1.8.1>= 1.9.0, < 1.16.0 | 1.1.11.8.11.16.0 |
| GHSA-25mx-8f3v-8wh7 sequoia-openpgp vulnerable to out-of-bounds array access leading to panic |
Medium EPSS 0.33% |
>= 1.2.0, < 1.8.1 | 1.8.1 |
| GHSA-25mx-8f3v-8wh7 sequoia-openpgp vulnerable to out-of-bounds array access leading to panic |
Medium EPSS 0.33% |
>= 1.9.0, < 1.16.0 | 1.16.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor