GHSA-v6x3-9r38-r27q CVE-2025-67897 RUSTSEC-2025-0136
Sequoia PGP has Subtraction Overflow when aes_key_unwrap function is provided ciphertext that is too short
- Severity
- 5.3 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.35%
- Chance of exploitation in the next 30 days. Higher than 29.16% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-195 Signed to Unsigned Conversion Error
- Fix
2.1.0- Upgrade sequoia-openpgp to this version or later
Description
In Sequoia before 2.1.0, aes_key_unwrap panics if passed a ciphertext that is too short. A remote attacker can take advantage of this issue to crash an application by sending a victim an encrypted message with a crafted PKESK or SKESK packet.
Affected versions
crates.io
| Package | Vulnerable | Fixed in |
|---|---|---|
| sequoia-openpgp | < 2.1.0 |
2.1.0 |
| sequoia-openpgp | >= 0.0.0-0, < 2.1.0 |
2.1.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
sequoia-openpgp crates.io → 2.1.0
- cargo
cargo update -p sequoia-openpgp --precise 2.1.0
Severity breakdown
CVSS 3.1 5.3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-195: Signed to Unsigned Conversion Error
The product uses a signed primitive and performs a cast to an unsigned primitive, which can produce an unexpected value if the value of the signed primitive can not be represented using an unsigned primitive.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-9344-p847-qm5c Low severity (DoS) vulnerability in sequoia-openpgp | High | Also affects sequoia-openpgp |
| GHSA-25mx-8f3v-8wh7 sequoia-openpgp vulnerable to out-of-bounds array access leading to panic | Medium | Also affects sequoia-openpgp |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor