Skip to content

deno_runtime (crates.io)

Advisories
6
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 1.31.2 or later clears every advisory below that has a fix.

Upgrade commands
cargo
cargo update -p deno_runtime --precise 1.31.2

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-7w8p-chxq-2789
Deno.env.toObject() ignores the variables listed in --deny-env and returns all environment variables
Medium
EPSS 0.44%
< 0.212.0
0.212.0
GHSA-xqxc-x6p3-w683
Deno run with --allow-read and --deny-read flags results in allowed
Medium
EPSS 0.42%
>= 0.150.0, < 0.212.0
0.212.0
GHSA-m4pq-fv2w-6hrw
Deno's deno_runtime vulnerable to interactive permission prompt spoofing via improper ANSI stripping
Medium
EPSS 0.94%
>= 0.103.0, < 0.147.0
0.147.0
GHSA-vc52-gwm3-8v2f
Missing "--allow-net" permission check for built-in Node modules
Critical
EPSS 0.62%
>= 0.114.0, < 0.115.0
0.115.0
GHSA-vq67-rp93-65qf
Interactive `run` permission prompt spoofing via improper ANSI neutralization
High
EPSS 1.13%
>= 1.8.0, < 1.31.2
1.31.2
GHSA-c25x-cm9x-qqgx
Deno improperly handles resizable ArrayBuffer
Critical
EPSS 0.97%
>= 0.102.0, < 0.103.0
0.103.0
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor