Skip to content

deepseek-tui (crates.io)

Advisories
13
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 0.8.26 or later clears every advisory below that has a fix.

Upgrade commands
cargo
cargo update -p deepseek-tui --precise 0.8.26

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-h539-c7r8-3xq4
CodeWhale: js_execution leaks parent environment to model context via missing env scrub
High
EPSS 0.68%
>= 0.8.32, <= 0.8.41
No fix yet
GHSA-w7wx-5q49-r59w
CodeWhale: image_analyze follows workspace symlinks, leaking external file bytes
High
EPSS 0.53%
>= 0.8.32, <= 0.8.41
No fix yet
GHSA-7j5w-7r7x-9v27
CodeWhale: Argument Injection in `git_show` Tool Allows Arbitrary File Write Without Approval
Critical
EPSS 0.48%
>= 0.3.27, <= 0.8.41
No fix yet
GHSA-c6mw-8xh8-gpq6
CodeWhale: Argument Injection in `git_blame` Tool Allows Arbitrary File Read Without Approval
High
EPSS 0.45%
>= 0.3.27, <= 0.8.41
No fix yet
GHSA-gx45-xrj5-g6c4
CodeWhale: Project config `allow_shell` override enables arbitrary shell command execution via cloned repository
High
EPSS 0.25%
>= 0.8.6, <= 0.8.41
No fix yet
GHSA-62f5-cp2p-vq95
CodeWhale: Project config `instructions` override enables arbitrary file read into AI system prompt via cloned repository
High
EPSS 0.53%
>= 0.8.8
No fix yet
GHSA-wrj3-vj8c-784f
CodeWhale: rlm_eval auto-approves arbitrary Python execution, bypassing the user's approval policy (RCE)
High
EPSS 0.36%
>= 0.8.33, <= 0.8.41
No fix yet
GHSA-g29h-pfmp-qp9r
CodeWhale: exec_shell_interact sends LLM-controlled input to a running shell without an approval prompt (privilege escalation)
High
EPSS 0.15%
>= 0.3.10, <= 0.8.41
No fix yet
GHSA-6v2g-fpxh-pmmh
CodeWhale: SSRF‌ bypass - TOCTOU on DNS failure for DNS pinning
High
EPSS 0.50%
>= 0.8.5, <= 0.8.41
No fix yet
GHSA-72w5-pf8h-xfp4
DeepSeek TUI: task_create Insecure Defaults Enable RCE via Prompt Injection in Project Files
Critical
EPSS 0.39%
< 0.8.26
0.8.26
GHSA-88gh-2526-gfrr
DeepSeek TUI has SSRF‌ IPV6 bypass
High
EPSS 0.30%
< 0.8.26
0.8.26
GHSA-wx44-2q6h-j6p8
DeepSeek TUI: run_tests Tool Enables RCE via Malicious Repository Without Approval
Critical
EPSS 0.57%
>= 0.3.0, < 0.8.23
0.8.23
GHSA-96ff-gc8g-wpvg
DeepSeek TUI has SSRF via HTTP Redirect Bypass in fetch_url Tool
High
EPSS 0.28%
< 0.8.22
0.8.22
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor