GHSA-88gh-2526-gfrr CVE-2026-45373
DeepSeek TUI has SSRF IPV6 bypass
- Severity
- 7.4 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 0.30%
- Chance of exploitation in the next 30 days. Higher than 23.11% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-918 Server-Side Request Forgery (SSRF)
- Fix
0.8.26- Upgrade deepseek-tui to this version or later
Description
Summary
Although SSRF is validated against hostnames that resolve to private IPv6 addresses, when providing the IPV6 in URL as http://[::1], the SSRF defenses do not work.
Details
PoC
Prompt: Run fetch_url tool and give output, no thinking. Use url : http://[::1]
Impact
Access to local restricted resources
Affected versions
crates.io
| Package | Vulnerable | Fixed in |
|---|---|---|
| deepseek-tui | < 0.8.26 |
0.8.26 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
deepseek-tui crates.io → 0.8.26
- cargo
cargo update -p deepseek-tui --precise 0.8.26
Severity breakdown
CVSS 3.1 7.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Changed
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-918: Server-Side Request Forgery (SSRF)
The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-h539-c7r8-3xq4 CodeWhale: js_execution leaks parent environment to model context via missing env scrub | High | Also affects deepseek-tui |
| GHSA-w7wx-5q49-r59w CodeWhale: image_analyze follows workspace symlinks, leaking external file bytes | High | Also affects deepseek-tui |
| GHSA-7j5w-7r7x-9v27 CodeWhale: Argument Injection in `git_show` Tool Allows Arbitrary File Write Without Approval | Critical | Also affects deepseek-tui |
| GHSA-c6mw-8xh8-gpq6 CodeWhale: Argument Injection in `git_blame` Tool Allows Arbitrary File Read Without Approval | High | Also affects deepseek-tui |
| GHSA-gx45-xrj5-g6c4 CodeWhale: Project config `allow_shell` override enables arbitrary shell command execution via cloned repository | High | Also affects deepseek-tui |
| GHSA-62f5-cp2p-vq95 CodeWhale: Project config `instructions` override enables arbitrary file read into AI system prompt via cloned repository | High | Also affects deepseek-tui |
| GHSA-wrj3-vj8c-784f CodeWhale: rlm_eval auto-approves arbitrary Python execution, bypassing the user's approval policy (RCE) | High | Also affects deepseek-tui |
| GHSA-g29h-pfmp-qp9r CodeWhale: exec_shell_interact sends LLM-controlled input to a running shell without an approval prompt (privilege escalation) | High | Also affects deepseek-tui |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor