view_component (RubyGems)
Advisories
8
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 4.12.0 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update view_component # Gemfile: gem "view_component", ">= 4.12.0"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-9h85-g7w3-rh49 ViewComponent: Reused Component Instances Retain Stale Render Context |
Medium EPSS 0.33% |
>= 4.0.0, < 4.12.0 | 4.12.0 |
| GHSA-97jw-64cj-jc58 ViewComponent: around_render HTML-Safety Bypass |
High EPSS 0.45% |
>= 4.0.0, < 4.12.0 | 4.12.0 |
| GHSA-hg3h-g7xc-f7vp view_component: System Test Entry Point Path Check Allows Sibling Directory Escape |
High EPSS 0.41% |
>= 3.0.0, < 4.9.0 | 4.9.0 |
| GHSA-7f3r-gwc9-2995 view_component: Preview Route Can Dispatch Inherited Helper Methods |
Medium EPSS 0.34% |
>= 3.0.0, < 4.9.0 | 4.9.0 |
| GHSA-wf2x-8w6j-qw37 view_component Cross-site Scripting vulnerability |
Medium EPSS 0.50% |
< 2.83.0 | 2.83.0 |
| GHSA-wf2x-8w6j-qw37 view_component Cross-site Scripting vulnerability |
Medium EPSS 0.50% |
>= 3.0.0, < 3.9.0 | 3.9.0 |
| GHSA-cm9w-c4rj-r2cf Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in view_component |
High EPSS 1.09% |
>= 2.31.0, < 2.31.2 | 2.31.2 |
| GHSA-cm9w-c4rj-r2cf Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in view_component |
High EPSS 1.09% |
>= 2.32.0, < 2.49.1 | 2.49.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor