katello (RubyGems)
Advisories
9
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 4.21.0.rc1 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update katello # Gemfile: gem "katello", ">= 4.21.0.rc1"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-c43c-rf7g-5xpg katello: missing repository authorization in content_uploads exposes cross-product content existence |
Medium EPSS 0.22% |
< 4.21.0.rc1 | 4.21.0.rc1 |
| GHSA-fwj4-6wgp-mpxm Katello: Denial of Service and potential information disclosure via SQL injection |
Medium EPSS 0.27% |
< 4.19.1 | 4.19.1 |
| GHSA-m4wh-848j-9w2r Katello cleartext password storage issue |
Low EPSS 0.65% |
>= 3.0.0.0, < 3.12.2 | 3.12.2 |
| GHSA-5xv2-q475-rwrh Katello uses hard coded credential |
Critical EPSS 3.00% |
< 1.0.6 | 1.0.6 |
| GHSA-5xv2-q475-rwrh Katello uses hard coded credential |
Critical EPSS 3.00% |
>= 1.1.0, < 1.1.7 | 1.1.7 |
| GHSA-527r-mfmj-prqf Katello SQL Injection vulnerabilities |
High EPSS 1.84% |
< 2.4.3 | 2.4.3 |
| GHSA-mhhc-r88h-2qrm katello Cross-site Scripting vulnerability |
Medium EPSS 1.00% |
< 3.9.0 | 3.9.0 |
| GHSA-cpv6-pfq6-j2v7 katello Improper Privilege Management vulnerability |
Medium EPSS 0.94% |
< 3.17.0.rc1 | 3.17.0.rc1 |
| GHSA-jx5v-788g-qw58 katello SQL Injection vulnerability |
Medium EPSS 1.43% |
<= 3.10 | No fix yet |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor