json (RubyGems)
Advisories
10
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.21.2 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update json # Gemfile: gem "json", ">= 2.21.2"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-9hj4-r449-hfvc Ruby JSON: JSON::ResumableParser#partial_value dereferences a freed input buffer and crashes on truncated duplicate-key streams |
High EPSS 0.43% |
>= 2.20.0, < 2.21.2 | 2.21.2 |
| GHSA-x2f5-4prf-w687 Ruby json: JSON generator heap buffer overflow when streaming to an IO |
Low EPSS 0.41% |
>= 2.9.0, < 2.19.9 | 2.19.9 |
| GHSA-3m6g-2423-7cp3 Ruby JSON has a format string injection vulnerability |
Critical EPSS 0.87% |
>= 2.16.0, < 2.17.1.2 | 2.17.1.2 |
| GHSA-3m6g-2423-7cp3 Ruby JSON has a format string injection vulnerability |
Critical EPSS 0.87% |
>= 2.14.0, < 2.15.2.1 | 2.15.2.1 |
| GHSA-3m6g-2423-7cp3 Ruby JSON has a format string injection vulnerability |
Critical EPSS 0.87% |
>= 2.18.0, < 2.19.2 | 2.19.2 |
| GHSA-9m3q-rhmv-5q44 Out-of-bounds Read in Ruby JSON Parser |
High EPSS 0.72% |
>= 2.10.0, < 2.10.2 | 2.10.2 |
| GHSA-jphg-qwrw-7w9g Unsafe object creation in json RubyGem |
High EPSS 6.81% |
< 2.3.0 | 2.3.0 |
| GHSA-x457-cw4h-hq5f JSON gem has Improper Input Validation vulnerability |
High EPSS 13.91% |
< 1.5.5 | 1.5.5 |
| GHSA-x457-cw4h-hq5f JSON gem has Improper Input Validation vulnerability |
High EPSS 13.91% |
>= 1.7.0, < 1.7.7 | 1.7.7 |
| GHSA-x457-cw4h-hq5f JSON gem has Improper Input Validation vulnerability |
High EPSS 13.91% |
>= 1.6.0, < 1.6.8 | 1.6.8 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor