Skip to content

activerecord (RubyGems)

Advisories
63
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 8.0.2.1 or later clears every advisory below that has a fix.

Upgrade commands
bundler
bundle update activerecord # Gemfile: gem "activerecord", ">= 8.0.2.1"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-76r7-hhxj-r776
Active Record logging vulnerable to ANSI escape injection
Medium
EPSS 0.59%
>= 8.0, < 8.0.2.1
8.0.2.1
GHSA-76r7-hhxj-r776
Active Record logging vulnerable to ANSI escape injection
Medium
EPSS 0.59%
< 7.1.5.2
7.1.5.2
GHSA-76r7-hhxj-r776
Active Record logging vulnerable to ANSI escape injection
Medium
EPSS 0.59%
>= 7.2, < 7.2.2.2
7.2.2.2
GHSA-579w-22j4-4749
Denial of Service Vulnerability in ActiveRecord's PostgreSQL adapter
High
EPSS 1.26%
>= 7.0.0, < 7.0.4.1
7.0.4.1
GHSA-579w-22j4-4749
Denial of Service Vulnerability in ActiveRecord's PostgreSQL adapter
High
EPSS 1.26%
< 6.1.7.1
6.1.7.1
GHSA-hq7p-j377-6v63
SQL Injection Vulnerability via ActiveRecord comments
High
EPSS 2.15%
>= 6.1.0, < 6.1.7.1
6.1.7.1
GHSA-hq7p-j377-6v63
SQL Injection Vulnerability via ActiveRecord comments
High
EPSS 2.15%
>= 6.0.0, < 6.0.6.1
6.0.6.1
GHSA-hq7p-j377-6v63
SQL Injection Vulnerability via ActiveRecord comments
High
EPSS 2.15%
>= 7.0.0, < 7.0.4.1
7.0.4.1
GHSA-3hhc-qp5v-9p2j
Active Record RCE bug with Serialized Columns
Critical
EPSS 2.60%
>= 6.1.0, < 6.1.6.1
6.1.6.1
GHSA-3hhc-qp5v-9p2j
Active Record RCE bug with Serialized Columns
Critical
EPSS 2.60%
>= 7.0.0, < 7.0.3.1
7.0.3.1
GHSA-3hhc-qp5v-9p2j
Active Record RCE bug with Serialized Columns
Critical
EPSS 2.60%
< 5.2.8.1
5.2.8.1
GHSA-3hhc-qp5v-9p2j
Active Record RCE bug with Serialized Columns
Critical
EPSS 2.60%
>= 6.0.0, < 6.0.5.1
6.0.5.1
GHSA-f57c-hx33-hvh8
Active Record component in Ruby on Rails has a data-type injection vulnerability
Critical
EPSS 1.96%
< 4.2.0
4.2.0
GHSA-8hc4-xxm3-5ppp
Active Record subject to Regular Expression Denial-of-Service (ReDoS)
High
EPSS 4.43%
>= 5.0.0, < 5.2.4.5
5.2.4.5
GHSA-8hc4-xxm3-5ppp
Active Record subject to Regular Expression Denial-of-Service (ReDoS)
High
EPSS 4.43%
>= 6.0.0, < 6.0.3.5
6.0.3.5
GHSA-8hc4-xxm3-5ppp
Active Record subject to Regular Expression Denial-of-Service (ReDoS)
High
EPSS 4.43%
>= 6.1.0, < 6.1.2.1
6.1.2.1
GHSA-7phj-gmgx-2r66
Moderate severity vulnerability that affects activerecord
Withdrawn
Medium
>= 4.0.0, < 4.1.14.1
4.1.14.1
GHSA-7phj-gmgx-2r66
Moderate severity vulnerability that affects activerecord
Withdrawn
Medium
>= 4.2.0, < 4.2.5.1
4.2.5.1
GHSA-7phj-gmgx-2r66
Moderate severity vulnerability that affects activerecord
Withdrawn
Medium
>= 3.0.0, < 3.2.22.1
3.2.22.1
GHSA-hm48-76wh-q86v
High severity vulnerability that affects activerecord
Withdrawn
High
>= 4.0.0, < 4.0.9
4.0.9
GHSA-hm48-76wh-q86v
High severity vulnerability that affects activerecord
Withdrawn
High
>= 4.1.0, < 4.1.5
4.1.5
GHSA-m8h6-m9p5-p2f8
Moderate severity vulnerability that affects activerecord
Withdrawn
Medium
>= 4.2.0, < 4.2.7.1
4.2.7.1
GHSA-gjxw-5w2q-7grf
Rails activerecord gem has Improper Input Validation vulnerability
Medium
EPSS 2.21%
>= 2.3.9, < 2.3.10
2.3.10
GHSA-76wq-xw4h-f8wj
activerecord vulnerable to SQL Injection
High
EPSS 2.95%
>= 3.0.0.beta, < 3.0.14
3.0.14
GHSA-76wq-xw4h-f8wj
activerecord vulnerable to SQL Injection
High
EPSS 2.95%
>= 3.1.0, < 3.1.6
3.1.6
GHSA-76wq-xw4h-f8wj
activerecord vulnerable to SQL Injection
High
EPSS 2.95%
>= 3.2.0, < 3.2.6
3.2.6
GHSA-76wq-xw4h-f8wj
activerecord vulnerable to SQL Injection
High
EPSS 2.95%
< 2.3.15
2.3.15
GHSA-fh39-v733-mxfr
Active Record vulnerable to SQL Injection via nested query parameters
Medium
EPSS 4.04%
>= 3.0.0, < 3.0.13
3.0.13
GHSA-fh39-v733-mxfr
Active Record vulnerable to SQL Injection via nested query parameters
Medium
EPSS 4.04%
>= 3.1.0, < 3.1.5
3.1.5
GHSA-fh39-v733-mxfr
Active Record vulnerable to SQL Injection via nested query parameters
Medium
EPSS 4.04%
>= 3.2.0, < 3.2.4
3.2.4
GHSA-gjxw-5w2q-7grf
Rails activerecord gem has Improper Input Validation vulnerability
Medium
EPSS 2.21%
>= 3.0.0, < 3.0.1
3.0.1
GHSA-h6w6-xmqv-7q78
activerecord vulnerable to SQL Injection
High
EPSS 2.32%
>= 2.0.0, < 2.3.13
2.3.13
GHSA-h6w6-xmqv-7q78
activerecord vulnerable to SQL Injection
High
EPSS 2.32%
>= 3.0.0.beta, < 3.0.10
3.0.10
GHSA-h6w6-xmqv-7q78
activerecord vulnerable to SQL Injection
High
EPSS 2.32%
>= 3.1.0.beta1, < 3.1.0.rc5
3.1.0.rc5
GHSA-jmm9-2p29-vh2w
activerecord vulnerable to SQL Injection
High
EPSS 2.17%
>= 3.0.0, < 3.0.4
3.0.4
GHSA-xf96-32q2-9rw2
Rails ActiveRecord gem vulnerable to SQL injection
High
EPSS 3.03%
< 2.1.1
2.1.1
GHSA-gppp-5xc5-wfpx
Active Record allows bypassing of database-query restrictions
Medium
EPSS 8.24%
>= 3.0.0, < 3.0.19
3.0.19
GHSA-gppp-5xc5-wfpx
Active Record allows bypassing of database-query restrictions
Medium
EPSS 8.24%
>= 3.2.0, < 3.2.11
3.2.11
GHSA-gr44-7grc-37vq
ActiveRecord vulnerable to modification of protected model attributes
Medium
EPSS 3.00%
< 2.3.17
2.3.17
GHSA-gr44-7grc-37vq
ActiveRecord vulnerable to modification of protected model attributes
Medium
EPSS 3.00%
>= 3.1.0, < 3.1.11
3.1.11
GHSA-gr44-7grc-37vq
ActiveRecord vulnerable to modification of protected model attributes
Medium
EPSS 3.00%
>= 3.2.0, < 3.2.12
3.2.12
GHSA-gh2w-j7cx-2664
Active Record contains SQL Injection
High
EPSS 4.58%
>= 3.0.0.beta, < 3.0.18
3.0.18
GHSA-fhj9-cjjh-27vm
Active Record contains deserialization of arbitrary YAML
Critical
EPSS 7.50%
>= 3.0.0, < 3.1.0
3.1.0
GHSA-fhj9-cjjh-27vm
Active Record contains deserialization of arbitrary YAML
Critical
EPSS 7.50%
< 2.3.17
2.3.17
GHSA-3crr-9vmg-864v
Active Record Improper Input Validation
Medium
EPSS 3.50%
>= 3.1.0, < 3.1.12
3.1.12
GHSA-3crr-9vmg-864v
Active Record Improper Input Validation
Medium
EPSS 3.50%
>= 2.3.0, < 2.3.18
2.3.18
GHSA-gh2w-j7cx-2664
Active Record contains SQL Injection
High
EPSS 4.58%
< 2.3.15
2.3.15
GHSA-3crr-9vmg-864v
Active Record Improper Input Validation
Medium
EPSS 3.50%
>= 3.2.0, < 3.2.13
3.2.13
GHSA-gh2w-j7cx-2664
Active Record contains SQL Injection
High
EPSS 4.58%
>= 3.2.0, < 3.2.10
3.2.10
GHSA-gh2w-j7cx-2664
Active Record contains SQL Injection
High
EPSS 4.58%
>= 3.1.0, < 3.1.9
3.1.9
GHSA-gppp-5xc5-wfpx
Active Record allows bypassing of database-query restrictions
Medium
EPSS 8.24%
>= 3.1.0, < 3.1.10
3.1.10
GHSA-9rf5-jm6f-2fmm
Active Record subject to strong parameters protection bypass
High
EPSS 2.80%
>= 4.1.0, < 4.1.5
4.1.5
GHSA-r8fh-hq2p-7qhq
Active Record contains SQL Injection via improper range quoting
High
EPSS 4.18%
>= 4.1.0, < 4.1.3
4.1.3
GHSA-xrr6-3pc4-m447
Active Record Improper Access Control
Medium
EPSS 4.25%
>= 5.0.0.beta1, < 5.0.0.beta1.1
5.0.0.beta1.1
GHSA-r8fh-hq2p-7qhq
Active Record contains SQL Injection via improper range quoting
High
EPSS 4.18%
>= 4.0.0, < 4.0.7
4.0.7
GHSA-9rf5-jm6f-2fmm
Active Record subject to strong parameters protection bypass
High
EPSS 2.80%
>= 4.0.0, < 4.0.9
4.0.9
GHSA-mhwp-qhpc-h3jm
SQL Injection in Active Record
High
EPSS 4.28%
>= 2.0.0, < 3.2.19
3.2.19
GHSA-xrr6-3pc4-m447
Active Record Improper Access Control
Medium
EPSS 4.25%
>= 4.2.0, < 4.2.5.1
4.2.5.1
GHSA-xrr6-3pc4-m447
Active Record Improper Access Control
Medium
EPSS 4.25%
>= 3.1.0, < 3.2.22.1
3.2.22.1
GHSA-hqf9-rc9j-5fmj
Array data injection vulnerability in activerecord
Medium
EPSS 1.27%
>= 4.0.0, < 4.0.3
4.0.3
GHSA-hqf9-rc9j-5fmj
Array data injection vulnerability in activerecord
Medium
EPSS 1.27%
>= 4.1.0.beta1, < 4.1.0.beta2
4.1.0.beta2
GHSA-xrr6-3pc4-m447
Active Record Improper Access Control
Medium
EPSS 4.25%
>= 4.0.0, < 4.1.14.1
4.1.14.1
GHSA-pr3r-4wrp-r2pv
ActiveRecord in Ruby on Rails allows database-query bypass
High
EPSS 3.90%
>= 4.2.0, < 4.2.7.1
4.2.7.1
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor