Skip to content

actionview (RubyGems)

Advisories
44
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 8.1.2.1 or later clears every advisory below that has a fix.

Upgrade commands
bundler
bundle update actionview # Gemfile: gem "actionview", ">= 8.1.2.1"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-v55j-83pf-r9cq
Rails has a possible XSS vulnerability in its Action View tag helpers
Low
EPSS 0.68%
< 7.2.3.1
7.2.3.1
GHSA-v55j-83pf-r9cq
Rails has a possible XSS vulnerability in its Action View tag helpers
Low
EPSS 0.68%
>= 8.0.0.beta1, < 8.0.4.1
8.0.4.1
GHSA-v55j-83pf-r9cq
Rails has a possible XSS vulnerability in its Action View tag helpers
Low
EPSS 0.68%
>= 8.1.0.beta1, < 8.1.2.1
8.1.2.1
GHSA-xp5h-f8jf-rc8q
rails-ujs vulnerable to DOM Based Cross-site Scripting contenteditable HTML Elements
Medium
EPSS 0.64%
>= 5.1.0, < 6.1.7.3
6.1.7.3
GHSA-xp5h-f8jf-rc8q
rails-ujs vulnerable to DOM Based Cross-site Scripting contenteditable HTML Elements
Medium
EPSS 0.64%
>= 7.0.0, < 7.0.4.3
7.0.4.3
GHSA-ch3h-j2vf-95pv
XSS Vulnerability in Action View tag helpers
Medium
EPSS 1.67%
>= 6.1.0, < 6.1.5.1
6.1.5.1
GHSA-ch3h-j2vf-95pv
XSS Vulnerability in Action View tag helpers
Medium
EPSS 1.67%
< 5.2.7.1
5.2.7.1
GHSA-ch3h-j2vf-95pv
XSS Vulnerability in Action View tag helpers
Medium
EPSS 1.67%
>= 7.0.0, < 7.0.2.4
7.0.2.4
GHSA-ch3h-j2vf-95pv
XSS Vulnerability in Action View tag helpers
Medium
EPSS 1.67%
>= 6.0.0, < 6.0.4.8
6.0.4.8
GHSA-cfjv-5498-mph5
XSS in Action View
Medium
EPSS 2.37%
< 5.2.4.4
5.2.4.4
GHSA-cfjv-5498-mph5
XSS in Action View
Medium
EPSS 2.37%
>= 6.0.0.0, < 6.0.3.3
6.0.3.3
GHSA-cr3x-7m39-c6jq
Remote code execution via user-provided local names in ActionView
High
EPSS 82.47%
< 4.2.11.3
4.2.11.3
GHSA-xq5j-gw7f-jgj8
CSRF Vulnerability in rails-ujs
Medium
EPSS 1.49%
>= 6.0.0, < 6.0.3.1
6.0.3.1
GHSA-xq5j-gw7f-jgj8
CSRF Vulnerability in rails-ujs
Medium
EPSS 1.49%
>= 5.0.0, < 5.2.4.3
5.2.4.3
GHSA-65cv-r6x7-79hv
Cross site scripting vulnerability in ActionView
Medium
EPSS 1.52%
>= 6.0.0, < 6.0.2.2
6.0.2.2
GHSA-65cv-r6x7-79hv
Cross site scripting vulnerability in ActionView
Medium
EPSS 1.52%
< 5.2.4.2
5.2.4.2
CVE-2019-5418
Path Traversal in Action View
Known exploited
High
EPSS 98.51%
>= 4.0.0, < 4.2.11.1
4.2.11.1
CVE-2019-5418
Path Traversal in Action View
Known exploited
High
EPSS 98.51%
>= 5.2.0, < 5.2.2.1
5.2.2.1
CVE-2019-5418
Path Traversal in Action View
Known exploited
High
EPSS 98.51%
>= 5.0.0, <= 5.0.7.1
No fix yet
CVE-2019-5418
Path Traversal in Action View
Known exploited
High
EPSS 98.51%
>= 5.1.0, <= 5.1.6.1
No fix yet
CVE-2019-5418
Path Traversal in Action View
Known exploited
High
EPSS 98.51%
>= 5.0.0, < 5.0.7.2
5.0.7.2
CVE-2019-5418
Path Traversal in Action View
Known exploited
High
EPSS 98.51%
>= 5.1.0, < 5.1.6.2
5.1.6.2
CVE-2019-5418
Path Traversal in Action View
Known exploited
High
EPSS 98.51%
>= 5.2.0, <= 5.2.2.0
No fix yet
CVE-2019-5418
Path Traversal in Action View
Known exploited
High
EPSS 98.51%
>= 4.0.0, <= 4.2.11.0
No fix yet
GHSA-m63j-wh5w-c252
Denial of Service Vulnerability in Action View
High
EPSS 8.78%
>= 5.1.0, < 5.1.6.2
5.1.6.2
GHSA-m63j-wh5w-c252
Denial of Service Vulnerability in Action View
High
EPSS 8.78%
>= 6.0.0.beta1, < 6.0.0.beta3
6.0.0.beta3
GHSA-m63j-wh5w-c252
Denial of Service Vulnerability in Action View
High
EPSS 8.78%
>= 4.0.0, < 4.2.11.1
4.2.11.1
GHSA-m63j-wh5w-c252
Denial of Service Vulnerability in Action View
High
EPSS 8.78%
>= 5.2.0, < 5.2.2.1
5.2.2.1
GHSA-m63j-wh5w-c252
Denial of Service Vulnerability in Action View
High
EPSS 8.78%
>= 5.0.0, < 5.0.7.2
5.0.7.2
GHSA-6834-r92f-jj42
Moderate severity vulnerability that affects actionview
Withdrawn
Medium
>= 4.2.0, < 4.2.5.1
4.2.5.1
GHSA-6834-r92f-jj42
Moderate severity vulnerability that affects actionview
Withdrawn
Medium
>= 4.1.0, < 4.1.14.1
4.1.14.1
GHSA-2pwf-xwr3-hp55
Moderate severity vulnerability that affects actionview
Withdrawn
Medium
>= 4.0.0, < 4.1.14.2
4.1.14.2
GHSA-2pwf-xwr3-hp55
Moderate severity vulnerability that affects actionview
Withdrawn
Medium
>= 3.2.0, < 3.2.22.2
3.2.22.2
GHSA-75w6-p6mg-vh8j
Rails actionpack gem vulnerable to Cross-site Scripting
Medium
EPSS 2.35%
>= 3.0.0, < 3.0.4
3.0.4
GHSA-75w6-p6mg-vh8j
Rails actionpack gem vulnerable to Cross-site Scripting
Medium
EPSS 2.35%
< 2.3.11
2.3.11
GHSA-pc3m-v286-2jwj
actionview Cross-site Scripting vulnerability
Medium
EPSS 3.44%
>= 3.0.0, < 3.2.22.3
3.2.22.3
GHSA-vx9j-46rh-fqr8
actionview contains Path Traversal vulnerability
Medium
EPSS 4.42%
>= 4.0.0, < 4.1.14.2
4.1.14.2
GHSA-xrr4-p6fq-hjg7
Directory traversal vulnerability in Action View in Ruby on Rails
Known exploited
High
EPSS 95.54%
>= 4.2.0, <= 4.2.5.0
No fix yet
GHSA-xrr4-p6fq-hjg7
Directory traversal vulnerability in Action View in Ruby on Rails
Known exploited
High
EPSS 95.54%
>= 4.0.0, <= 4.1.14.0
No fix yet
GHSA-xrr4-p6fq-hjg7
Directory traversal vulnerability in Action View in Ruby on Rails
Known exploited
High
EPSS 95.54%
>= 4.2.0, < 4.2.5.1
4.2.5.1
GHSA-xrr4-p6fq-hjg7
Directory traversal vulnerability in Action View in Ruby on Rails
Known exploited
High
EPSS 95.54%
>= 4.0.0, < 4.1.14.1
4.1.14.1
GHSA-vx9j-46rh-fqr8
actionview contains Path Traversal vulnerability
Medium
EPSS 4.42%
>= 3.0.0, < 3.2.22.2
3.2.22.2
GHSA-pc3m-v286-2jwj
actionview Cross-site Scripting vulnerability
Medium
EPSS 3.44%
>= 4.0.0, < 4.2.7.1
4.2.7.1
GHSA-pc3m-v286-2jwj
actionview Cross-site Scripting vulnerability
Medium
EPSS 3.44%
>= 5.0.0, < 5.0.0.1
5.0.0.1
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor