Skip to content

langflow-base (PyPI)

Advisories
14
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 0.10.3 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "langflow-base>=0.10.3"
poetry
poetry add "langflow-base>=0.10.3"
uv
uv add "langflow-base>=0.10.3"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-j8f7-x8jm-wmm4
Langflow: SSRF in URL-taking components (protection disabled by default / warn-only, not applied to RSS, SearXNG, Web Search, Home Assistant, Glean, Docling)
Medium
< 0.10.3
0.10.3
GHSA-gh98-4phw-6fmw
Langflow : Cross-user flow access and vertex execution via deprecated /api/v1/build/{flow_id}/vertices endpoints
Medium
EPSS 0.22%
< 0.10.1
0.10.1
GHSA-gh98-4phw-6fmw
Langflow : Cross-user flow access and vertex execution via deprecated /api/v1/build/{flow_id}/vertices endpoints
Medium
EPSS 0.22%
< 0.10.1
0.10.1
GHSA-w794-rj3p-xv45
Langflow: OS command injection (RCE) via arbitrary command in MCP stdio server configuration
Critical
EPSS 1.05%
>= 0.1.2, < 0.10.3
0.10.3
GHSA-w794-rj3p-xv45
Langflow: OS command injection (RCE) via arbitrary command in MCP stdio server configuration
Critical
EPSS 1.05%
>= 0.1.2, < 0.10.3
0.10.3
GHSA-8c4j-f57c-35cf
Langflow: Authenticated Users Can Read, Modify, and Delete Any Flow via Missing Ownership Check
High
EPSS 0.48%
< 0.5.1
0.5.1
GHSA-8c4j-f57c-35cf
Langflow: Authenticated Users Can Read, Modify, and Delete Any Flow via Missing Ownership Check
High
EPSS 0.48%
< 0.5.1
0.5.1
GHSA-c5cp-vx83-jhqx
Langflow Missing Authentication on Critical API Endpoints
Critical
EPSS 33.29%
< 0.7.1
0.7.1
GHSA-c5cp-vx83-jhqx
Langflow Missing Authentication on Critical API Endpoints
Critical
EPSS 33.29%
< 0.7.1
0.7.1
GHSA-4gv9-mp8m-592r
Langflow Vulnerable to Privilege Escalation via CLI Superuser Creation (Post-RCE)
High
EPSS 0.54%
< 0.5.1
0.5.1
GHSA-4gv9-mp8m-592r
Langflow Vulnerable to Privilege Escalation via CLI Superuser Creation (Post-RCE)
High
EPSS 0.54%
< 0.5.1
0.5.1
GHSA-rvqx-wpfh-mfx7
Langflow Unauth RCE
Known exploited
Critical
EPSS 99.99%
< 0.3.0
0.3.0
GHSA-rvqx-wpfh-mfx7
Langflow Unauth RCE
Known exploited
Critical
EPSS 99.99%
< 0.3.0
0.3.0
GHSA-rvqx-wpfh-mfx7
Langflow Unauth RCE
Known exploited
Critical
EPSS 99.99%
< 0.3.0
0.3.0
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor