langchain-community (PyPI)
Advisories
6
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 0.3.0 or later clears every advisory below that has a fix.
Upgrade commands
pip
pip install --upgrade "langchain-community>=0.3.0"poetry
poetry add "langchain-community>=0.3.0"uv
uv add "langchain-community>=0.3.0"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-45pg-36p6-83v9 Langchain SQL Injection vulnerability |
Critical EPSS 13.74% |
>= 0.2.0, < 0.2.19 | 0.2.19 |
| GHSA-45pg-36p6-83v9 Langchain SQL Injection vulnerability |
Critical EPSS 13.74% |
>= 0.2.0, < 0.3.0 | 0.3.0 |
| PYSEC-2024-323 LangChain pickle deserialization of untrusted data |
High EPSS 0.36% |
< 0.2.4 | 0.2.4 |
| PYSEC-2024-323 LangChain pickle deserialization of untrusted data |
High EPSS 0.36% |
< 0.2.4 | 0.2.4 |
| GHSA-3hjh-jh2h-vrg6 Denial of service in langchain-community |
Medium EPSS 0.30% |
< 0.2.5 | 0.2.5 |
| GHSA-3hjh-jh2h-vrg6 Denial of service in langchain-community |
Medium EPSS 0.30% |
< 0.2.5 | 0.2.5 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor