Skip to content

keystonemiddleware (PyPI)

Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 4.1.0 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "keystonemiddleware>=4.1.0"
poetry
poetry add "keystonemiddleware>=4.1.0"
uv
uv add "keystonemiddleware>=4.1.0"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-8c4w-v65p-jvcv
OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials
High
EPSS 2.00%
>= 2.4.0, < 4.1.0
4.1.0
GHSA-8c4w-v65p-jvcv
OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials
High
EPSS 2.00%
< 1.5.4
1.5.4
GHSA-8c4w-v65p-jvcv
OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials
High
EPSS 2.00%
>= 1.6.0, < 2.3.3
2.3.3
GHSA-8c4w-v65p-jvcv
OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials
High
EPSS 2.00%
< 1.5.4
>= 1.6.0, < 2.3.3
1.5.4
2.3.3
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor