GHSA-8c4w-v65p-jvcv CVE-2015-7546 PYSEC-2016-20 PYSEC-2026-2549
OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials
- Severity
- 0.0 / 10
- High · CVSS 4.0
- Exploit chance (EPSS)
- 2.00%
- Chance of exploitation in the next 30 days. Higher than 80.73% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-522 Insufficiently Protected Credentials
- Fix
- Available
- 2 packages have a fixed version
Description
The identity service in OpenStack Identity (Keystone) before 2015.1.3 (Kilo) and 8.0.x before 8.0.2 (Liberty) and keystonemiddleware (formerly python-keystoneclient) before 1.5.4 (Kilo) and Liberty before 2.3.3 does not properly invalidate authorization tokens when using the PKI or PKIZ token providers, which allows remote authenticated users to bypass intended access restrictions and gain access to cloud resources by manipulating byte fields within a revoked token.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| keystone | >= 9.0.0.0b1, < 9.0.0.0b2 |
9.0.0.0b2 |
| keystone | >= 8.0, < 8.1.0 |
8.1.0 |
| keystone | >= 8.0, < 8.1.0>= 9.0.0.0b1, < 9.0.0.0b2 |
8.1.09.0.0.0b2 |
| keystonemiddleware | >= 2.4.0, < 4.1.0 |
4.1.0 |
| keystonemiddleware | < 1.5.4 |
1.5.4 |
| keystonemiddleware | >= 1.6.0, < 2.3.3 |
2.3.3 |
| keystonemiddleware | < 1.5.4>= 1.6.0, < 2.3.3 |
1.5.42.3.3 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
keystone PyPI → 9.0.0.0b2
- pip
pip install --upgrade "keystone>=9.0.0.0b2"- poetry
poetry add "keystone>=9.0.0.0b2"- uv
uv add "keystone>=9.0.0.0b2"
keystonemiddleware PyPI → 4.1.0
- pip
pip install --upgrade "keystonemiddleware>=4.1.0"- poetry
poetry add "keystonemiddleware>=4.1.0"- uv
uv add "keystonemiddleware>=4.1.0"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- Passive
- Confidentiality (vulnerable system)
- High
- Integrity (vulnerable system)
- High
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 7.5
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-522: Insufficiently Protected Credentials
The product transmits or stores authentication credentials, but it uses an insecure method that is susceptible to unauthorized interception and/or retrieval.
How to prevent it
- Architecture and Design: Use an appropriate security mechanism to protect the credentials.
- Architecture and Design: Make appropriate use of cryptography to protect the credentials.
- Implementation: Use industry standards to protect the credentials (e.g. LDAP, keystore, etc.).
References
Advisories
Packages
Other links
- github.com/openstack/keystone/commit/bff03b5726fe5cac93d44a66715eea49b89c8cb0
- github.com/openstack/keystone/commit/d5378f173da14a34ca010271477337879002d6d0
- github.com/openstack/keystonemiddleware/commit/96ab58e6863c92575ada57615b19652e…
- bugs.launchpad.net/keystone/+bug/1490804
- github.com/pypa/advisory-database/tree/main/vulns/keystonemiddleware/PYSEC-2016…
- security.openstack.org/ossa/OSSA-2016-005.html
- web.archive.org/web/20200228002640/http://www.securityfocus.com/bid/80498
- wiki.openstack.org/wiki/OSSN/OSSN-0062
- oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- securityfocus.com/bid/80498
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-whqr-fgm5-x77q OpenStack Keystone's federated token rescoping mechanism doesn't propagate the original token's expiry to the newly issued token | High | Also affects keystone |
| GHSA-q623-f4j4-p4xj OpenStack Keystone has an Incorrect Authorization issue | High | Also affects keystone |
| GHSA-2r23-2g6v-2m5f OpenStack Keystone has an Authorization Bypass | High | Also affects keystone |
| GHSA-8f8m-wrvr-wcvf OpenStack Keystone doesn't verify that the user supplied in the authentication request matches the owner of the application credential | High | Also affects keystone |
| GHSA-hhq2-3832-xxcv OpenStack Keystone has an Incorrect Authorization Issue | High | Also affects keystone |
| GHSA-pfx2-9x9m-7ghx OpenStack Keystone: LDAP identity backend does not convert enabled attribute to boolean | High | Also affects keystone |
| GHSA-4phw-6824-6cfp OpenStack Keystone: Restricted application credentials can create EC2 credentials | Medium | Also affects keystone |
| GHSA-hcqg-5g63-7j9h OpenStack Keystone allows /v3/ec2tokens or /v3/s3tokens request with valid AWS Signature to provide Keystone authorization. | High | Also affects keystone |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor