symfony/dom-crawler (Packagist)
Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 8.0.12 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require symfony/dom-crawler:^8.0.12Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-x6g4-fwcc-jj8w Symfony has XXE (Local File Disclosure) in DomCrawler::addXmlContent() via validateOnParse = true |
High EPSS 0.57% |
< 5.4.52 | 5.4.52 |
| GHSA-x6g4-fwcc-jj8w Symfony has XXE (Local File Disclosure) in DomCrawler::addXmlContent() via validateOnParse = true |
High EPSS 0.57% |
>= 6.0.0, < 6.4.40 | 6.4.40 |
| GHSA-x6g4-fwcc-jj8w Symfony has XXE (Local File Disclosure) in DomCrawler::addXmlContent() via validateOnParse = true |
High EPSS 0.57% |
>= 7.0.0, < 7.4.12 | 7.4.12 |
| GHSA-x6g4-fwcc-jj8w Symfony has XXE (Local File Disclosure) in DomCrawler::addXmlContent() via validateOnParse = true |
High EPSS 0.57% |
>= 8.0.0, < 8.0.12 | 8.0.12 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor