silverstripe/assets (Packagist)
Advisories
5
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 1.11.1 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require silverstripe/assets:^1.11.1Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-9cx2-hj6m-fv58 Silverstripe XSS in shortcodes |
Medium EPSS 0.71% |
>= 1.0.0, < 1.11.1 | 1.11.1 |
| GHSA-592m-4533-rxq9 SilverStripe Folders migrated from 3.x may be unsafe to upload to |
High EPSS 1.73% |
>= 1.0.0, < 1.4.7 | 1.4.7 |
| GHSA-592m-4533-rxq9 SilverStripe Folders migrated from 3.x may be unsafe to upload to |
High EPSS 1.73% |
>= 1.5.0, < 1.5.2 | 1.5.2 |
| GHSA-jvx5-rm6q-gx7p Lack of access control on upoaded files |
Medium EPSS 1.37% |
>= 1.0.0, < 1.3.5 | 1.3.5 |
| GHSA-jvx5-rm6q-gx7p Lack of access control on upoaded files |
Medium EPSS 1.37% |
>= 1.4.0, < 1.4.4 | 1.4.4 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor