org.jenkins-ci.plugins:script-security (Maven)
Advisories
39
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 1402.1405.vc96e74964250 or later clears every advisory below that has a fix.
Upgrade commands
maven
<dependency><groupId>org.jenkins-ci.plugins</groupId><artifactId>script-security</artifactId><version>1402.1405.vc96e74964250</version></dependency>gradle
implementation("org.jenkins-ci.plugins:script-security:1402.1405.vc96e74964250")Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-cfj9-2vgr-hpxp Jenkins Script Security Plugin has a script security bypass vulnerability |
High EPSS 0.92% |
< 1402.1405.vc96e74964250 | 1402.1405.vc96e74964250 |
| GHSA-c3jm-9vj7-5v66 Jenkins Script Security Plugin sandbox bypass vulnerability |
High EPSS 0.51% |
< 1402.1405.vc96e74964250 | 1402.1405.vc96e74964250 |
| GHSA-p334-gfhq-c7w6 Jenkins Script Security Plugin: Missing permission checks allow enumeration of pending and approved classpaths |
Medium EPSS 0.17% |
< 1402.v94c9ce464861 | 1402.v94c9ce464861 |
| GHSA-jv82-75fh-23r7 Missing permission check in Jenkins Script Security Plugin |
Medium EPSS 0.35% |
< 1368.vb | 1368.vb |
| GHSA-2g4q-9vm9-9fw4 Jenkins Script Security Plugin sandbox bypass vulnerability |
High EPSS 1.00% |
< 1336.vf33a | 1336.vf33a |
| GHSA-v63g-v339-2673 Jenkins Script Security Plugin has sandbox bypass vulnerability involving crafted constructor bodies |
Critical EPSS 48.36% |
< 1336.vf33a | 1336.vf33a |
| GHSA-76qj-9gwh-pvv3 Sandbox bypass in Jenkins Script Security Plugin |
High EPSS 0.58% |
< 1229.v4880b | 1229.v4880b |
| GHSA-fv42-mx39-6fpw Whole-script approval in Jenkins Script Security Plugin vulnerable to SHA-1 collisions |
High EPSS 0.51% |
< 1190.v65867a_a_47126 | 1190.v65867a_a_47126 |
| GHSA-27rf-8mjp-r363 Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin |
Critical EPSS 1.39% |
< 1184.v85d16b_d851b_3 | 1184.v85d16b_d851b_3 |
| GHSA-f6mq-6fx5-w2ch Jenkins Script Security Plugin sandbox bypass vulnerability |
Critical EPSS 1.89% |
< 1184.v85d16b_d851b_3 | 1184.v85d16b_d851b_3 |
| GHSA-7vr5-72w7-q6jc Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin |
Critical EPSS 1.54% |
< 1184.v85d16b_d851b_3 | 1184.v85d16b_d851b_3 |
| GHSA-ccr8-4xr7-cgj3 Sandbox bypass vulnerability in Jenkins Script Security Plugin |
Critical EPSS 2.13% |
>= 1.67, < 1.75 | 1.75 |
| GHSA-ccr8-4xr7-cgj3 Sandbox bypass vulnerability in Jenkins Script Security Plugin |
Critical EPSS 2.13% |
< 1.66.5 | 1.66.5 |
| GHSA-q87g-7mp5-765q Improper Neutralization of Input During Web Page Generation in Jenkins Script Security Plugin |
Medium EPSS 0.75% |
< 1.73 | 1.73 |
| GHSA-gj3q-p8cm-26rm Sandbox bypass vulnerability in Script Security Plugin |
High EPSS 1.01% |
< 1.7.1 | 1.7.1 |
| GHSA-qvhf-3567-pc4v Sandbox bypass vulnerability in Script Security Plugin |
High EPSS 1.01% |
< 1.71 | 1.71 |
| GHSA-qvmf-36h5-3f5v Improper Input Validation in Jenkins Script Security Plugin |
High EPSS 1.26% |
< 1.70 | 1.70 |
| GHSA-62pm-mgrh-7p69 Incorrect Authorization in Jenkins Script Security Plugin |
High EPSS 1.42% |
< 1.68 | 1.68 |
| GHSA-72gx-qq2m-6xr2 Improper Control of Generation of Code in Jenkins Script Security Plugin |
Critical EPSS 2.75% |
< 1.65 | 1.65 |
| GHSA-76q7-r3g4-wvm4 Sandbox bypass vulnerability in Jenkins Script Security Plugin |
Medium EPSS 1.04% |
< 1.63 | 1.63 |
| GHSA-m26f-w3h5-62fj Sandbox bypass vulnerability in Jenkins Script Security Plugin |
Medium EPSS 1.04% |
< 1.63 | 1.63 |
| GHSA-hvmx-5hv4-f235 Sandbox bypass vulnerability in Jenkins Script Security Plugin |
Medium EPSS 1.04% |
< 1.63 | 1.63 |
| GHSA-9fp8-64xf-w957 Sandbox bypass vulnerability in Script Security Plugin |
Medium EPSS 1.04% |
< 1.63 | 1.63 |
| GHSA-x25x-j4w4-7m59 Return of Pointer Value Outside of Expected Rang in Jenkins Script Security Plugin |
High EPSS 2.50% |
< 1.62 | 1.62 |
| GHSA-p56j-x44h-g66j Incorrect Privilege Assignment in Jenkins Script Security Plugin |
High EPSS 2.50% |
< 1.62 | 1.62 |
| GHSA-qwgx-mrv5-87j8 CSRF vulnerability in Jenkins Script Security Plugin |
Medium EPSS 0.65% |
< 1172.v35f6a | 1172.v35f6a |
| GHSA-xgjx-96v4-mqxx Jenkins Script Security Plugin allows for Bypass of Groovy Sandbox Protection |
High EPSS 1.77% |
< 1.18.1 | 1.18.1 |
| GHSA-r9jf-hf9x-7hrv Exposure of Sensitive Information to an Unauthorized Actor Jenkins Script Security Plugin |
Medium EPSS 0.99% |
< 1.37 | 1.37 |
| GHSA-p4p5-3v2j-w5rv Improper Privilege Management in Jenkins |
High EPSS 1.64% |
< 1.48 | 1.48 |
| GHSA-gqhm-4h93-rrhg Jenkins Script Security and Pipeline Groovy Plugins Sandbox Bypass |
High EPSS 1.64% |
< 1.48 | 1.48 |
| GHSA-h7rx-r733-7x7r Sandbox bypass in Jenkins Script Security Plugin sandbox bypass |
High EPSS 1.20% |
< 1.31 | 1.31 |
| GHSA-m68x-cc2f-gr5h Unsafe methods in the default list of approved signatures in Jenkins Script Security Plugin |
Medium EPSS 0.82% |
< 1.29.1 | 1.29.1 |
| GHSA-jgpm-2862-q5m8 Jenkins Script Security Plugin sandbox bypass vulnerability |
High EPSS 3.05% |
< 1.53 | 1.53 |
| GHSA-6q78-6xvr-26fg Jenkins Groovy Plugin sandbox bypass vulnerability |
High EPSS 86.05% |
< 1.50 | 1.50 |
| GHSA-784j-h234-m56x Protection Mechanism Failure in Jenkins Script Security Plugin |
High EPSS 98.38% |
< 1.50 | 1.50 |
| GHSA-3pv3-jj4h-p528 Sandbox bypass vulnerability in Jenkins Script Security Plugin |
Critical EPSS 3.43% |
< 1.56 | 1.56 |
| GHSA-x5jm-rj37-5qh7 Sandbox Bypass in Script Security Plugin |
High EPSS 19.54% |
< 1.51 | 1.51 |
| CVE-2019-1003029 Sandbox bypass in Script Security Plugin Known exploited |
Critical EPSS 74.44% |
< 1.54 | 1.54 |
| CVE-2019-1003029 Sandbox bypass in Script Security Plugin Known exploited |
Critical EPSS 74.44% |
< 1.54 | 1.54 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor