GHSA-ccr8-4xr7-cgj3 CVE-2020-2279
Sandbox bypass vulnerability in Jenkins Script Security Plugin
- Severity
- 9.9 / 10
- Critical · CVSS 3.1
- Exploit chance (EPSS)
- 2.13%
- Chance of exploitation in the next 30 days. Higher than 81.93% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-693 Protection Mechanism Failure
- Fix
1.75- Upgrade org.jenkins-ci.plugins:script-security to this version or later
Description
Jenkins Script Security Plugin provides a sandbox feature that allows low privileged users to define scripts, including Pipelines, that are generally safe to execute. Calls to code defined inside a sandboxed script are intercepted, and various allowlists are checked to determine whether the call is to be allowed.
In Script Security Plugin 1.75 and 1.66.5, any calls from outside a sandboxed script to code defined inside a sandboxed script were always allowed. As sandboxed scripts can communicate their results through script return values and similar mechanisms, this could result in code defined inside of a sandboxed script to be called without sandbox protection.
This vulnerability allows attackers with permission to define and run sandboxed scripts, including Pipelines, to bypass the sandbox protection and execute arbitrary code in the context of the Jenkins controller JVM.
Script Security Plugin 1.75 and 1.66.5 will prevent code defined inside a sandbox from being invoked outside a sandboxed script.
In rare cases, invocations of sandboxed scripts may begin failing if the script return value or script binding include code defined in the sandbox and is further processed by the calling code. To resolve this issue, the affected values need to be converted inside the sandboxed script to a known safe type, such as String.
For compatibility with this change, the following plugins should be upgraded to the versions specified:
- Email Extension Plugin should be updated to version 2.77 or newer.
- Warnings Next Generation Plugin should be updated to version 8.4.3 or newer.
- Warnings Plugin should be updated to version 5.0.2 or newer.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.jenkins-ci.plugins:script-security | >= 1.67, < 1.75 |
1.75 |
| org.jenkins-ci.plugins:script-security | < 1.66.5 |
1.66.5 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.jenkins-ci.plugins:script-security Maven → 1.75
- maven
<dependency><groupId>org.jenkins-ci.plugins</groupId><artifactId>script-security</artifactId><version>1.75</version></dependency>- gradle
implementation("org.jenkins-ci.plugins:script-security:1.75")
Severity breakdown
CVSS 3.1 9.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Changed
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-693: Protection Mechanism Failure
The product does not use or incorrectly uses a protection mechanism that provides sufficient defense against directed attacks against the product.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| CVE-2019-1003029 Sandbox bypass in Script Security Plugin | Critical Known exploited | Also affects org.jenkins-ci.plugins:script-security |
| GHSA-cfj9-2vgr-hpxp Jenkins Script Security Plugin has a script security bypass vulnerability | High | Also affects org.jenkins-ci.plugins:script-security |
| GHSA-c3jm-9vj7-5v66 Jenkins Script Security Plugin sandbox bypass vulnerability | High | Also affects org.jenkins-ci.plugins:script-security |
| GHSA-p334-gfhq-c7w6 Jenkins Script Security Plugin: Missing permission checks allow enumeration of pending and approved classpaths | Medium | Also affects org.jenkins-ci.plugins:script-security |
| GHSA-jv82-75fh-23r7 Missing permission check in Jenkins Script Security Plugin | Medium | Also affects org.jenkins-ci.plugins:script-security |
| GHSA-2g4q-9vm9-9fw4 Jenkins Script Security Plugin sandbox bypass vulnerability | High | Also affects org.jenkins-ci.plugins:script-security |
| GHSA-v63g-v339-2673 Jenkins Script Security Plugin has sandbox bypass vulnerability involving crafted constructor bodies | Critical | Also affects org.jenkins-ci.plugins:script-security |
| GHSA-76qj-9gwh-pvv3 Sandbox bypass in Jenkins Script Security Plugin | High | Also affects org.jenkins-ci.plugins:script-security |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor