github.com/jackc/pgx/v5 (Go)
PostgreSQL driver and toolkit for Go
Advisories
15
Latest version
v5.11.0
Released Sep 7, 2026
License
MIT
OpenSSF Scorecard
4.5 / 10
How to fix
Upgrading to 5.9.2 or later clears every advisory below that has a fix.
Upgrade commands
go
go get github.com/jackc/pgx/v5@v5.11.0 && go mod tidyKnown vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-j88v-2chj-qfwx pgx: SQL Injection via placeholder confusion with dollar quoted string literals |
Low EPSS 0.36% |
< 5.9.2 | 5.9.2 |
| GHSA-j88v-2chj-qfwx pgx: SQL Injection via placeholder confusion with dollar quoted string literals |
Low EPSS 0.36% |
< 5.9.2 | 5.9.2 |
| GHSA-j88v-2chj-qfwx pgx: SQL Injection via placeholder confusion with dollar quoted string literals |
Low EPSS 0.36% |
< 5.9.2 | 5.9.2 |
| GHSA-9jj7-4m8r-rfcm Memory-safety vulnerability in github.com/jackc/pgx/v5. |
Critical EPSS 0.56% |
< 5.9.0 | 5.9.0 |
| GHSA-9jj7-4m8r-rfcm Memory-safety vulnerability in github.com/jackc/pgx/v5. |
Critical EPSS 0.56% |
< 5.9.0 | 5.9.0 |
| GHSA-9jj7-4m8r-rfcm Memory-safety vulnerability in github.com/jackc/pgx/v5. |
Critical EPSS 0.56% |
< 5.9.0 | 5.9.0 |
| GHSA-xgrm-4fwx-7qm8 pgx contains memory-safety vulnerability |
Critical EPSS 0.60% |
< 5.9.0 | 5.9.0 |
| GHSA-xgrm-4fwx-7qm8 pgx contains memory-safety vulnerability |
Critical EPSS 0.60% |
< 5.9.0 | 5.9.0 |
| GHSA-xgrm-4fwx-7qm8 pgx contains memory-safety vulnerability |
Critical EPSS 0.60% |
< 5.9.0 | 5.9.0 |
| GHSA-fqpg-rq76-99pq Panic in Pipeline when PgConn is busy or closed in github.com/jackc/pgx |
Medium | < 5.5.2 | 5.5.2 |
| GHSA-fqpg-rq76-99pq Panic in Pipeline when PgConn is busy or closed in github.com/jackc/pgx |
Medium | < 5.5.2 | 5.5.2 |
| GHSA-fqpg-rq76-99pq Panic in Pipeline when PgConn is busy or closed in github.com/jackc/pgx |
Medium | >= 5.0.0-alpha.5, < 5.5.2 | 5.5.2 |
| GHSA-mrww-27vc-gghv pgproto3 SQL Injection via Protocol Message Size Overflow |
High EPSS 1.11% |
>= 5.0.0, < 5.5.4 | 5.5.4 |
| GHSA-mrww-27vc-gghv pgproto3 SQL Injection via Protocol Message Size Overflow |
High EPSS 1.11% |
>= 5.0.0, < 5.5.4 | 5.5.4 |
| GHSA-mrww-27vc-gghv pgproto3 SQL Injection via Protocol Message Size Overflow |
High EPSS 1.11% |
>= 5.0.0, < 5.5.4 | 5.5.4 |
Source: https://github.com/jackc/pgx
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor