Skip to content

github.com/answerdev/answer (Go)

Advisories
68
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 1.1.3 or later clears every advisory below that has a fix.

Upgrade commands
go
go get github.com/answerdev/answer@v1.1.3 && go mod tidy

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-pj2h-85jq-g5vg
Answer Missing Authentication for Critical Function
High
EPSS 0.82%
< 1.1.3
1.1.3
GHSA-pj2h-85jq-g5vg
Answer Missing Authentication for Critical Function
High
EPSS 0.82%
< 1.1.3
1.1.3
GHSA-52h8-c876-989c
Answer has Race Condition within a Thread
Medium
EPSS 0.48%
< 1.1.1
1.1.1
GHSA-52h8-c876-989c
Answer has Race Condition within a Thread
Medium
EPSS 0.48%
< 1.1.1
1.1.1
GHSA-ggcf-hwxp-rc77
Answer Insufficient Session Expiration vulnerability
High
EPSS 0.57%
< 1.1.0
1.1.0
GHSA-ggcf-hwxp-rc77
Answer Insufficient Session Expiration vulnerability
High
EPSS 0.57%
< 1.1.0
1.1.0
GHSA-j63x-f657-2m9g
Answer has Weak Password Requirements
High
EPSS 0.88%
< 1.1.0
1.1.0
GHSA-j63x-f657-2m9g
Answer has Weak Password Requirements
High
EPSS 0.88%
< 1.1.0
1.1.0
GHSA-v9vc-7x69-c2x8
Answer Missing Authorization vulnerability
Medium
EPSS 0.65%
< 1.1.1
1.1.1
GHSA-v9vc-7x69-c2x8
Answer Missing Authorization vulnerability
Medium
EPSS 0.65%
< 1.1.1
1.1.1
GHSA-qmqw-r4x6-3w2q
Answer Missing Authorization vulnerability
Low
EPSS 0.46%
< 1.0.9
1.0.9
GHSA-qmqw-r4x6-3w2q
Answer Missing Authorization vulnerability
Low
EPSS 0.46%
< 1.0.9
1.0.9
GHSA-j97g-77fj-9c4p
Answer vulnerable to account takeover because password reset links do not expire
High
EPSS 0.61%
< 1.0.6
1.0.6
GHSA-j97g-77fj-9c4p
Answer vulnerable to account takeover because password reset links do not expire
High
EPSS 0.61%
< 1.0.6
1.0.6
GHSA-65v8-6pvw-jwvq
Answer vulnerable to Insertion of Sensitive Information Into Sent Data
Medium
EPSS 0.59%
< 1.0.8
1.0.8
GHSA-65v8-6pvw-jwvq
Answer vulnerable to Insertion of Sensitive Information Into Sent Data
Medium
EPSS 0.59%
< 1.0.8
1.0.8
GHSA-8jg3-rx43-3fv4
Answer vulnerable to Exposure of Sensitive Information Through Metadata
Medium
EPSS 0.60%
< 1.0.8
1.0.8
GHSA-8jg3-rx43-3fv4
Answer vulnerable to Exposure of Sensitive Information Through Metadata
Medium
EPSS 0.60%
< 1.0.8
1.0.8
GHSA-79hx-g43v-xfmr
Answer vulnerable to Insufficient Session Expiration
High
EPSS 0.78%
< 1.0.6
1.0.6
GHSA-79hx-g43v-xfmr
Answer vulnerable to Insufficient Session Expiration
High
EPSS 0.78%
< 1.0.6
1.0.6
GHSA-r95w-7cpx-h5mx
Answer vulnerable to Business Logic Errors
Medium
EPSS 0.75%
< 1.0.6
1.0.6
GHSA-r95w-7cpx-h5mx
Answer vulnerable to Business Logic Errors
Medium
EPSS 0.75%
< 1.0.6
1.0.6
GHSA-h2wg-83fc-xvm9
Answer vulnerable to Business Logic Errors
Low
EPSS 0.64%
< 1.0.6
1.0.6
GHSA-h2wg-83fc-xvm9
Answer vulnerable to Business Logic Errors
Low
EPSS 0.64%
< 1.0.6
1.0.6
GHSA-6x5v-cxpp-pc5x
Answer has Observable Response Discrepancy
Medium
EPSS 0.64%
< 1.0.6
1.0.6
GHSA-6x5v-cxpp-pc5x
Answer has Observable Response Discrepancy
Medium
EPSS 0.64%
< 1.0.6
1.0.6
GHSA-g44v-6qfm-f6ch
Answer has Guessable CAPTCHA
Medium
EPSS 0.61%
< 1.0.6
1.0.6
GHSA-g44v-6qfm-f6ch
Answer has Guessable CAPTCHA
Medium
EPSS 0.61%
< 1.0.6
1.0.6
GHSA-rvjp-8qj4-8p29
Answer has Observable Timing Discrepancy
Medium
EPSS 0.64%
< 1.0.6
1.0.6
GHSA-rvjp-8qj4-8p29
Answer has Observable Timing Discrepancy
Medium
EPSS 0.64%
< 1.0.6
1.0.6
GHSA-hwj7-frgj-7829
Answer vulnerable to Authentication Bypass by Capture-replay
Critical
EPSS 0.84%
< 1.0.6
1.0.6
GHSA-hwj7-frgj-7829
Answer vulnerable to Authentication Bypass by Capture-replay
Critical
EPSS 0.84%
< 1.0.6
1.0.6
GHSA-xvfj-84vc-hrmf
Answer vulnerable to Stored Cross-site Scripting
Medium
EPSS 0.52%
< 1.0.7
1.0.7
GHSA-xvfj-84vc-hrmf
Answer vulnerable to Stored Cross-site Scripting
Medium
EPSS 0.52%
< 1.0.7
1.0.7
GHSA-83qr-c7m9-wmgw
Answer vulnerable to Stored Cross-site Scripting
Medium
EPSS 0.54%
< 1.0.7
1.0.7
GHSA-83qr-c7m9-wmgw
Answer vulnerable to Stored Cross-site Scripting
Medium
EPSS 0.54%
< 1.0.7
1.0.7
GHSA-6c32-3x46-m9rh
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.52%
< 1.0.6
1.0.6
GHSA-6c32-3x46-m9rh
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.52%
< 1.0.6
1.0.6
GHSA-h85v-cx5m-78wj
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.52%
< 1.0.6
1.0.6
GHSA-h85v-cx5m-78wj
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.52%
< 1.0.6
1.0.6
GHSA-8jh8-33f5-cgfp
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.53%
< 1.0.6
1.0.6
GHSA-8jh8-33f5-cgfp
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.53%
< 1.0.6
1.0.6
GHSA-qrwm-xqfr-4vhv
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.62%
< 1.0.6
1.0.6
GHSA-qrwm-xqfr-4vhv
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.62%
< 1.0.6
1.0.6
GHSA-ff27-hrmr-ggpj
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.62%
< 1.0.6
1.0.6
GHSA-ff27-hrmr-ggpj
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.62%
< 1.0.6
1.0.6
GHSA-55vm-3vq3-4jpc
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.62%
< 1.0.6
1.0.6
GHSA-55vm-3vq3-4jpc
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.62%
< 1.0.6
1.0.6
GHSA-vxhr-p2vp-7gf8
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.53%
< 1.0.6
1.0.6
GHSA-vxhr-p2vp-7gf8
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.53%
< 1.0.6
1.0.6
GHSA-5w78-v688-cx9q
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.55%
< 1.0.6
1.0.6
GHSA-5w78-v688-cx9q
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.55%
< 1.0.6
1.0.6
GHSA-9v4v-9fj5-p982
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.44%
< 1.0.6
1.0.6
GHSA-9v4v-9fj5-p982
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.44%
< 1.0.6
1.0.6
GHSA-6cvf-m58q-h9wf
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.39%
< 1.0.5
1.0.5
GHSA-6cvf-m58q-h9wf
Answer vulnerable to Cross-site Scripting
Medium
EPSS 0.39%
< 1.0.5
1.0.5
GHSA-4cwh-8w4g-jxxh
Answer contains Improper Access Control vulnerability
Critical
EPSS 6.37%
< 1.0.4
1.0.4
GHSA-4cwh-8w4g-jxxh
Answer contains Improper Access Control vulnerability
Critical
EPSS 6.37%
< 1.0.4
1.0.4
GHSA-hjmr-xm25-36mh
Answer subject to Cross-site Scripting vulnerability
Critical
EPSS 0.74%
< 1.0.4
1.0.4
GHSA-hjmr-xm25-36mh
Answer subject to Cross-site Scripting vulnerability
Critical
EPSS 0.74%
< 1.0.4
1.0.4
GHSA-rmw8-7823-wp7f
Answer contains Cross-site Scripting vulnerability
Critical
EPSS 0.87%
< 1.0.4
1.0.4
GHSA-rmw8-7823-wp7f
Answer contains Cross-site Scripting vulnerability
Critical
EPSS 0.87%
< 1.0.4
1.0.4
GHSA-p7wj-c85f-xq9h
Answer has Cross-site Scripting vulnerability
Critical
EPSS 0.87%
< 1.0.4
1.0.4
GHSA-p7wj-c85f-xq9h
Answer has Cross-site Scripting vulnerability
Critical
EPSS 0.87%
< 1.0.4
1.0.4
GHSA-65px-4cpf-697r
Cross-site scripting vulnerability found in answerdev/answer
Critical
EPSS 0.71%
< 1.0.4
1.0.4
GHSA-65px-4cpf-697r
Cross-site scripting vulnerability found in answerdev/answer
Critical
EPSS 0.71%
< 1.0.4
1.0.4
GHSA-qx34-47fc-vv79
Answer vulnerable to Race Condition
Medium
EPSS 0.69%
< 1.0.4
1.0.4
GHSA-qx34-47fc-vv79
Answer vulnerable to Race Condition
Medium
EPSS 0.69%
< 1.0.4
1.0.4
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor