Skip to content

PYSEC-2026-3990 BIT-airflow-2026-86473 CVE-2026-86473

Apache Airflow: the Core API logout endpoint revokes only a session token presented as the _token cookie.

Critical PyPI
Severity
9.1 / 10
Critical · CVSS 3.1
Exploit chance (EPSS)
0.75%
Chance of exploitation in the next 30 days. Higher than 54.88% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-613 Insufficient Session Expiration
Fix
3.3.2
Upgrade apache-airflow to this version or later

Description

Apache Airflow: the Core API logout endpoint revokes only a session token presented as the _token cookie. When a client logs out presenting its credential as an Authorization bearer header instead, the endpoint returns its normal logout response but revokes nothing, so the token remains valid until it expires. An attacker who already holds a copy of that token keeps the victim's access after the victim has logged out and believes the session ended; the default token lifetime is 24 hours and is configurable.

Affects API clients that authenticate with a bearer token rather than the browser session cookie. The attacker must already possess a copy of a valid token; obtaining one is outside the scope of this issue, and no privileges beyond the victim's own are gained.

Users of apache-airflow are recommended to upgrade to apache-airflow version 3.3.2 or later, which fixes the issue.

Affected versions

PyPI

PackageVulnerableFixed in
apache-airflow
>= 3.0.0, < 3.3.2
3.3.2

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

apache-airflow PyPI → 3.3.2

pip
pip install --upgrade "apache-airflow>=3.3.2"
poetry
poetry add "apache-airflow>=3.3.2"
uv
uv add "apache-airflow>=3.3.2"

Severity breakdown

CVSS 3.1 9.1

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
None

Weakness

CWE-613: Insufficient Session Expiration

According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization."

How to prevent it
  • Implementation: Set sessions/credentials expiration date.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
CVE-2020-13927
Authentication bypass in Apache Airflow
Critical Known exploited Also affects apache-airflow
CVE-2020-11978
Remote code execution (RCE) in Apache Airflow
High Known exploited Also affects apache-airflow
PYSEC-2026-3989
When a request to the Airflow core API carries both a session cookie and an explicit `Authorization: Bearer` token, Airflow resolves the caller from the cookie…
Medium Also affects apache-airflow
PYSEC-2026-3988
Apache Airflow's `/assets/events` API returned asset events for every Dag in the deployment, with no filter restricting them to the Dags the caller is…
Medium Also affects apache-airflow
GHSA-5247-m8w9-2v4m
Apache Airflow missing team context permits cross-team Dag actions and XCom reads
Medium Also affects apache-airflow
GHSA-f3c2-j7g8-vpp8
Apache Airflow Task SDK fails to mask list-shaped JSON Variables
Medium Also affects apache-airflow
GHSA-cjv4-7hp2-2x9h
Apache Airflow bulk endpoints log Variable and Connection secrets in cleartext
Medium Also affects apache-airflow
GHSA-j4jc-cq9h-xrhr
Apache Airflow Backfill API parser discrepancy permits cross-DAG authorization bypass
High Also affects apache-airflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor