Skip to content

GHSA-j4jc-cq9h-xrhr BIT-airflow-2026-68968 CVE-2026-68968 PYSEC-2026-3710

Apache Airflow Backfill API parser discrepancy permits cross-DAG authorization bypass

High PyPI
Severity
7.5 / 10
High · CVSS 3.1
Exploit chance (EPSS)
0.42%
Chance of exploitation in the next 30 days. Higher than 35.97% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-436 Interpretation Conflict
Fix
3.3.1
Upgrade apache-airflow to this version or later

Description

Apache Airflow's Backfill API authorized a request against a Dag id supplied by the caller whenever the backfill_id path segment failed to parse. The authorization dependency parsed it with int() while the route handler parsed it as pydantic's NonNegativeInt, which accepts values int() rejects (1.0 coerces to 1); FastAPI resolves dependencies before endpoint validation, so the two acted on different Dags. An authenticated user holding edit permission on any single Dag could therefore read, pause and cancel backfills belonging to any other Dag, including moving another Dag's queued runs to failed. No non-default configuration is required and backfill ids are sequential, so finding a target is trivial. Users are advised to upgrade to apache-airflow 3.3.1 or later, which parses the backfill id with the same type the routes declare.

Affected versions

PyPI

PackageVulnerableFixed in
apache-airflow
< 3.3.1
3.3.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

apache-airflow PyPI → 3.3.1

pip
pip install --upgrade "apache-airflow>=3.3.1"
poetry
poetry add "apache-airflow>=3.3.1"
uv
uv add "apache-airflow>=3.3.1"

Severity breakdown

CVSS 3.1 7.5

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
None
Availability
None

Weakness

CWE-436: Interpretation Conflict

Product A handles inputs or steps differently than Product B, which causes A to perform incorrect actions based on its perception of B's state.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
CVE-2020-13927
Authentication bypass in Apache Airflow
Critical Known exploited Also affects apache-airflow
CVE-2020-11978
Remote code execution (RCE) in Apache Airflow
High Known exploited Also affects apache-airflow
PYSEC-2026-3990
Apache Airflow: the Core API logout endpoint revokes only a session token presented as the _token cookie.
Critical Also affects apache-airflow
PYSEC-2026-3989
When a request to the Airflow core API carries both a session cookie and an explicit `Authorization: Bearer` token, Airflow resolves the caller from the cookie…
Medium Also affects apache-airflow
PYSEC-2026-3988
Apache Airflow's `/assets/events` API returned asset events for every Dag in the deployment, with no filter restricting them to the Dags the caller is…
Medium Also affects apache-airflow
GHSA-5247-m8w9-2v4m
Apache Airflow missing team context permits cross-team Dag actions and XCom reads
Medium Also affects apache-airflow
GHSA-f3c2-j7g8-vpp8
Apache Airflow Task SDK fails to mask list-shaped JSON Variables
Medium Also affects apache-airflow
GHSA-cjv4-7hp2-2x9h
Apache Airflow bulk endpoints log Variable and Connection secrets in cleartext
Medium Also affects apache-airflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor