PYSEC-2025-87 CVE-2025-67895 GHSA-66h8-3g48-6hx8 PYSEC-2026-276
Apache Airflow Providers Edge3 exposes internal API allowing RCE in web server context
- Severity
- 9.8 / 10
- Critical · CVSS 3.1
- Exploit chance (EPSS)
- 1.17%
- Chance of exploitation in the next 30 days. Higher than 67.39% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-669 Incorrect Resource Transfer Between Spheres
- Fix
- Available
- 2 packages have a fixed version
Description
Edge3 Worker RPC RCE on Airflow 2.
This issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if you installed and configured it on Airflow 2.
The Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if you installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do.
If you installed and configured Edge3 provider for Airflow 2, you should uninstall it and migrate to Airflow 3. The new Edge3 provider versions (>=2.0.0) has minimum version of Airflow set to 3 and the RCE-prone Airflow 2 code is removed, so it should no longer be possible to use the Edge3 provider 2.0.0+ on Airflow 2.
If you used Edge Provider in Airflow 3, you are not affected.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| apache-airflow | < 2.0.0 |
2.0.0 |
| apache-airflow-providers-edge3 | < 2.0.0 |
2.0.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
apache-airflow PyPI → 2.0.0
- pip
pip install --upgrade "apache-airflow>=2.0.0"- poetry
poetry add "apache-airflow>=2.0.0"- uv
uv add "apache-airflow>=2.0.0"
apache-airflow-providers-edge3 PyPI → 2.0.0
- pip
pip install --upgrade "apache-airflow-providers-edge3>=2.0.0"- poetry
poetry add "apache-airflow-providers-edge3>=2.0.0"- uv
uv add "apache-airflow-providers-edge3>=2.0.0"
Severity breakdown
CVSS 3.1 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-669: Incorrect Resource Transfer Between Spheres
The product does not properly transfer a resource/behavior to another sphere, or improperly imports a resource/behavior from another sphere, in a manner that provides unintended control over that resource.
References
Advisories
Other links
- github.com/apache/airflow/pull/59143
- github.com/apache/airflow
- github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-edge…
- github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2025-87.…
- lists.apache.org/thread/hhnmmzkj5qx5gbk6pdkh8tcsx5oj1nqs
- pypi.org/project/apache-airflow-providers-edge3
- openwall.com/lists/oss-security/2025/12/16/3
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| CVE-2020-13927 Authentication bypass in Apache Airflow | Critical Known exploited | Also affects apache-airflow |
| CVE-2020-11978 Remote code execution (RCE) in Apache Airflow | High Known exploited | Also affects apache-airflow |
| PYSEC-2026-3990 Apache Airflow: the Core API logout endpoint revokes only a session token presented as the _token cookie. | Critical | Also affects apache-airflow |
| PYSEC-2026-3989 When a request to the Airflow core API carries both a session cookie and an explicit `Authorization: Bearer` token, Airflow resolves the caller from the cookie… | Medium | Also affects apache-airflow |
| PYSEC-2026-3988 Apache Airflow's `/assets/events` API returned asset events for every Dag in the deployment, with no filter restricting them to the Dags the caller is… | Medium | Also affects apache-airflow |
| GHSA-5247-m8w9-2v4m Apache Airflow missing team context permits cross-team Dag actions and XCom reads | Medium | Also affects apache-airflow |
| GHSA-f3c2-j7g8-vpp8 Apache Airflow Task SDK fails to mask list-shaped JSON Variables | Medium | Also affects apache-airflow |
| GHSA-cjv4-7hp2-2x9h Apache Airflow bulk endpoints log Variable and Connection secrets in cleartext | Medium | Also affects apache-airflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor