GHSA-w8vq-3hf9-xppx CVE-2023-41317
Apollo Router Unnamed "Subscription" operation results in Denial-of-Service
- Severity
- 5.9 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.80%
- Chance of exploitation in the next 30 days. Higher than 56.78% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-755 Improper Handling of Exceptional Conditions
- Fix
1.29.1- Upgrade apollo-router to this version or later
Description
Impact
This is a Denial-of-Service (DoS) type vulnerability which causes the Router to panic and terminate when GraphQL Subscriptions are enabled. It can be triggered when all of the following conditions are met:
- Running Apollo Router v1.28.0, v1.28.1 or v1.29.0 ("impacted versions"); and
- The Supergraph schema provided to the Router (either via Apollo Uplink or explicitly via other configuration) has a
subscriptiontype with root-fields defined; and - The YAML configuration provided to the Router has subscriptions enabled (they are disabled by default), either by setting
enabled: trueor by setting a validmodewithin thesubscriptionsobject (as seen in subscriptions' documentation); and - An anonymous (i.e., un-named)
subscriptionoperation (e.g.,subscription { ... }) is received by the Router
If all four of these criteria are met, the impacted versions will panic and terminate. There is no data-privacy risk or sensitive-information exposure aspect to this vulnerability.
Depending on the environment in which impacted versions are running and the high-availability characteristics of that environment, a single Router's termination may result in limited or reduced availability or other knock-on effects which are deployment-specific (e.g., depending on if there are multiple instances, auto-restart policies, etc.)
Discovery
This vulnerability was discovered by an internal Apollo team. We have no reports or evidence to support that that has been exploited outside of our own testing, research and follow-up.
Our public security policy can be reviewed at https://github.com/apollographql/router/security/policy and we consider the security of our projects a top priority. Please review the linked policy for more details.
Patches
This is fixed in Apollo Router v1.29.1, which is available on:
- GitHub Releases as
v1.29.1 - GitHub Packages Container Registry as
v1.29.1 - Helm Chart Repository as
1.29.1(without thev)
We recommend all users running the impacted configuration above to update to a patched version of the Router immediately. Router v1.29.1 should be a very simple upgrade from any impacted version.
Workarounds
Updating to v1.29.1 should be a clear and simple upgrade path for those running impacted versions. However, if Subscriptions are not necessary for your Graph – but are enabled via configuration — then disabling subscriptions is another option to mitigate the risk.
For more information
If you have any questions or comments about this advisory:
- Open an issue in the
routerrepository - Email us at
security[at]apollographql[dot]com
Affected versions
crates.io
| Package | Vulnerable | Fixed in |
|---|---|---|
| apollo-router | >= 1.28.0, < 1.29.1 |
1.29.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
apollo-router crates.io → 1.29.1
- cargo
cargo update -p apollo-router --precise 1.29.1
Severity breakdown
CVSS 3.1 5.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-755: Improper Handling of Exceptional Conditions
The product does not handle or incorrectly handles an exceptional condition.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-hff2-gcpx-8f4p Apollo Router Core: Browser Bug Enables Bypass of XS-Search Prevention via Read-Only Cross-Site Request Forgery | Medium | Also affects apollo-router |
| GHSA-x33c-7c2v-mrj9 Apollo Router Affected by an Access Control Bypass on Polymorphic Types | High | Also affects apollo-router |
| GHSA-g8jh-vg5j-4h3f Apollo Router Improperly Enforces Renamed Access Control Directives | High | Also affects apollo-router |
| GHSA-3j43-9v8v-cp3f Apollo Router Query Validation Vulnerable to Excessive Resource Consumption via Named Fragment Processing | High | Also affects apollo-router |
| GHSA-84m6-5m72-45fp Apollo Router Operation Limits Vulnerable to Bypass via Integer Overflow | High | Also affects apollo-router |
| GHSA-75m2-jhh5-j5g2 Apollo Router Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion | High | Also affects apollo-router |
| GHSA-94hh-jmq8-2fgp Apollo Router Query Planner Vulnerable to Excessive Resource Consumption via Optimization Bypass | High | Also affects apollo-router |
| GHSA-x6xq-whh3-gg32 Apollo Router Coprocessors may cause Denial-of-Service when handling request bodies | High | Also affects apollo-router |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor