GHSA-vw5v-4f2q-w9xf CVE-2026-3336 GHSA-cfwj-9wp5-wqvp RUSTSEC-2026-0046
AWS-LC has PKCS7_verify Certificate Chain Validation Bypass
- Severity
- 0.0 / 10
- High · CVSS 4.0
- Exploit chance (EPSS)
- 0.74%
- Chance of exploitation in the next 30 days. Higher than 54.77% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-295 Improper Certificate Validation
- Fix
0.38.0- Upgrade aws-lc-sys to this version or later
Description
Summary
AWS-LC is an open-source, general-purpose cryptographic library.
Impact
Improper certificate validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass certificate chain verification when processing PKCS7 objects with multiple signers, except the final signer.
Customers of AWS services do not need to take action. aws-lc-sys contains code from AWS-LC. Applications using aws-lc-sys should upgrade to the most recent release of aws-lc-sys.
Impacted versions:
aws-lc-sys versions: >= 0.24.0, < 0.38.0
Patches
The patch is included in v0.38.0
Workarounds
There is no workaround. Applications using aws-lc-sys should upgrade to the most recent release of aws-lc-sys.
Resources
If there are any questions or comments about this advisory, contact [AWS/Amazon] Security via the vulnerability reporting page or directly via email to aws-security@amazon.com. Please do not create a public GitHub issue.
Acknowledgement
AWS-LC would like to thank Joshua Rogers (https://joshua.hu/) for collaborating on this issue through the coordinated vulnerability disclosure process.
Affected versions
crates.io
| Package | Vulnerable | Fixed in |
|---|---|---|
| aws-lc-sys | >= 0.24.0, < 0.38.0 |
0.38.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
aws-lc-sys crates.io → 0.38.0
- cargo
cargo update -p aws-lc-sys --precise 0.38.0
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- None
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- High
- Availability (vulnerable system)
- None
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Weakness
CWE-295: Improper Certificate Validation
The product does not validate, or incorrectly validates, a certificate.
How to prevent it
- Architecture and Design, Implementation: Certificates should be carefully managed and checked to assure that data are encrypted with the intended owner's public key.
- Implementation: If certificate pinning is being used, ensure that all relevant properties of the certificate are fully validated before the certificate is pinned, including the hostname.
References
Advisories
Packages
Other links
- github.com/aws/aws-lc-rs/security/advisories/GHSA-vw5v-4f2q-w9xf
- github.com/aws/aws-lc/security/advisories/GHSA-cfwj-9wp5-wqvp
- aws.amazon.com/security/security-bulletins/2026-005-AWS
- rustsec.org/advisories/RUSTSEC-2026-0046.html
- github.com/aws/aws-lc/releases/tag/v1.69.0
- access.redhat.com/errata/RHSA-2026:5459
- access.redhat.com/security/cve/CVE-2026-3336
- bugzilla.redhat.com/show_bug.cgi
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-3336.json
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-9f94-5g5w-gf6r CRL Distribution Point Scope Check Logic Error in AWS-LC | Critical | Also affects aws-lc-sys |
| GHSA-394x-vwmw-crm3 AWS-LC X.509 Name Constraints Bypass via Wildcard/Unicode CN | High | Also affects aws-lc-sys |
| GHSA-hfpc-8r3f-gw53 AWS-LC has PKCS7_verify Signature Validation Bypass | High | Also affects aws-lc-sys |
| GHSA-65p9-r9h6-22vj AWS-LC has Timing Side-Channel in AES-CCM Tag Verification | Medium | Also affects aws-lc-sys |
| GHSA-4487-j8r4-4g2f Forge: verifyCertificateChain() removes trusted CA certificates with the same subject from the CA store | Low | Same weakness, CWE-295 |
| GHSA-5x38-2vff-x55p Forge: X.509 basicConstraints bypass in verifyCertificateChain() via deprecated extension OIDs 2.5.29.10 and 2.5.29.13 | High | Same weakness, CWE-295 |
| EEF-CVE-2026-115693 Custom cacerts or cacertfile do not restrict trust to the pinned CA in hackney | Not rated yet | Same weakness, CWE-295 |
| GHSA-6q48-6c7w-9gw2 certifi bundles emSign root CAs with compromised intermediate CA keys | Critical | Same weakness, CWE-295 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor