Skip to content

GHSA-vr7m-c6v4-8cx8 BIT-airflow-2026-48726 CVE-2026-48726 PYSEC-2026-187

Apache Airflow: Auth manager doesn't invalidate JWT tokens after users click logout

Medium PyPI
Severity
6.5 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
0.38%
Chance of exploitation in the next 30 days. Higher than 32.22% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-613 Insufficient Session Expiration
Fix
3.2.2
Upgrade apache-airflow to this version or later

Description

A bug in Apache Airflow's auth manager logout handling left previously-issued JWT tokens valid after the user clicked logout in the UI: the logout flow for FabAuthManager and KeycloakAuthManager did not actually reach the underlying revoke_token() call, so the JWT remained accepted by the API server until its natural expiry. An attacker holding a previously-issued JWT for a logged-out user could continue to make authenticated API calls as that user. Affects deployments configured with FabAuthManager or KeycloakAuthManager (the bug does not affect SimpleAuthManager). This is a residual gap in the fix for CVE-2025-57735, which addressed cookie-side invalidation in PR #57992 / PR #61339 but did not cover the provider-side revoke_token() reachability in the FAB / Keycloak code paths. Users who already upgraded for CVE-2025-57735 should additionally upgrade to apache-airflow 3.2.2 or later to cover the FAB / Keycloak logout paths.

Affected versions

PyPI

PackageVulnerableFixed in
apache-airflow
< 3.2.2
3.2.2

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

apache-airflow PyPI → 3.2.2

pip
pip install --upgrade "apache-airflow>=3.2.2"
poetry
poetry add "apache-airflow>=3.2.2"
uv
uv add "apache-airflow>=3.2.2"

Severity breakdown

CVSS 3.1 6.5

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
None
Availability
None

Weakness

CWE-613: Insufficient Session Expiration

According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization."

How to prevent it
  • Implementation: Set sessions/credentials expiration date.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
CVE-2020-13927
Authentication bypass in Apache Airflow
Critical Known exploited Also affects apache-airflow
CVE-2020-11978
Remote code execution (RCE) in Apache Airflow
High Known exploited Also affects apache-airflow
PYSEC-2026-3990
Apache Airflow: the Core API logout endpoint revokes only a session token presented as the _token cookie.
Critical Also affects apache-airflow
PYSEC-2026-3989
When a request to the Airflow core API carries both a session cookie and an explicit `Authorization: Bearer` token, Airflow resolves the caller from the cookie…
Medium Also affects apache-airflow
PYSEC-2026-3988
Apache Airflow's `/assets/events` API returned asset events for every Dag in the deployment, with no filter restricting them to the Dags the caller is…
Medium Also affects apache-airflow
GHSA-5247-m8w9-2v4m
Apache Airflow missing team context permits cross-team Dag actions and XCom reads
Medium Also affects apache-airflow
GHSA-f3c2-j7g8-vpp8
Apache Airflow Task SDK fails to mask list-shaped JSON Variables
Medium Also affects apache-airflow
GHSA-cjv4-7hp2-2x9h
Apache Airflow bulk endpoints log Variable and Connection secrets in cleartext
Medium Also affects apache-airflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor