GHSA-vjqc-g788-f378 CVE-2023-50270
Session Fixation Apache DolphinScheduler
- Severity
- 6.5 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 1.31%
- Chance of exploitation in the next 30 days. Higher than 70.56% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-613 Insufficient Session Expiration
- Fix
3.2.1- Upgrade org.apache.dolphinscheduler:dolphinscheduler to this version or later
Description
Session Fixation Apache DolphinScheduler before version 3.2.1, which session is still valid after the password change.
Users are recommended to upgrade to version 3.2.1, which fixes this issue.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.dolphinscheduler:dolphinscheduler | >= 1.3.8, < 3.2.1 |
3.2.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.dolphinscheduler:dolphinscheduler Maven → 3.2.1
- maven
<dependency><groupId>org.apache.dolphinscheduler</groupId><artifactId>dolphinscheduler</artifactId><version>3.2.1</version></dependency>- gradle
implementation("org.apache.dolphinscheduler:dolphinscheduler:3.2.1")
Severity breakdown
CVSS 3.1 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Weakness
CWE-613: Insufficient Session Expiration
According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization."
How to prevent it
- Implementation: Set sessions/credentials expiration date.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-72mv-wwvm-vgp5 Apache DolphinScheduler has an Incorrect Authorization Vulnerability | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-f786-9c63-8xr8 Apache DolphinScheduler RPC module has a Deserialization of Untrusted Data vulnerability | Medium | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-3cjc-vhfm-ffp2 Apache DolphinScheduler vulnerable to sensitive information disclosure | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-rrpj-r8h7-rm7r Apache DolphinScheduler Incorrect Default Permissions Vulnerability | Critical | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-3vcp-r62v-xpvg Apache DolphinScheduler vulnerable to Alert Script Attack | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-4vv4-crw4-8pcw Apache DolphinScheduler: Resource File Read And Write Vulnerability | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-m9q4-p56m-mc6q Apache DolphinScheduler: RCE by arbitrary js execution | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-ff2w-wm48-jhqj Arbitrary File Read Vulnerability in Apache Dolphinscheduler | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor