GHSA-rw75-m7gp-92m3 CVE-2014-0483 PYSEC-2014-7
Django data leakage via querystring manipulation in admin
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 1.98%
- Chance of exploitation in the next 30 days. Higher than 80.58% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
1.4.14- Upgrade django to this version or later
Description
The administrative interface (contrib.admin) in Django before 1.4.14, 1.5.x before 1.5.9, 1.6.x before 1.6.6, and 1.7 before release candidate 3 does not check if a field represents a relationship between models, which allows remote authenticated users to obtain sensitive information via a to_field parameter in a popup action to an admin change form page, as demonstrated by a /admin/auth/user/?pop=1&t=password URI.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| django | < 1.4.14 |
1.4.14 |
| django | >= 1.5, < 1.5.9 |
1.5.9 |
| django | >= 1.6, < 1.6.6 |
1.6.6 |
| django | >= 1.7a1, < 1.7c3 |
1.7c3 |
| django | < 1.4.14>= 1.5, < 1.5.9>= 1.6, < 1.6.6 |
1.4.141.5.91.6.6 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
django PyPI → 1.4.14
- pip
pip install --upgrade "django>=1.4.14"- poetry
poetry add "django>=1.4.14"- uv
uv add "django>=1.4.14"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- Low
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- None
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Write-ups
Packages
Other links
- github.com/django/django/commit/027bd348642007617518379f8b02546abacaa6e0
- github.com/django/django/commit/2a446c896e7c814661fb9c4f212b071b2a7fa446
- github.com/django/django/commit/2b31342cdf14fc20e07c43d258f1e7334ad664a6
- github.com/django/django/commit/f7c494f2506250b8cb5923714360a3642ed63e0f
- github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2014-7.yaml
- web.archive.org/web/20151016194735/http://secunia.com/advisories/61276
- web.archive.org/web/20151016202523/http://secunia.com/advisories/59782
- web.archive.org/web/20151023143840/http://secunia.com/advisories/61281
- djangoproject.com/weblog/2014/aug/20/security
- lists.opensuse.org/opensuse-updates/2014-09/msg00023.html
- debian.org/security/2014/dsa-3010
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-q238-5cxm-5c9h Django GeoDjango vulnerable to denial of service through deeply nested geometry collections | Medium | Also affects django |
| GHSA-wvqv-fj8w-qmhm Django GeoDjango spatial lookups allow file writes and outbound requests through GDAL raster parsing | High | Also affects django |
| GHSA-8qcx-xf44-272x Django: DomainNameValidator permits newline characters that may enable HTTP header injection | Medium | Also affects django |
| GHSA-crhf-3pfg-w68w Django: GDALRaster may over-read heap memory when constructed from bytes | Medium | Also affects django |
| GHSA-3h9f-r86x-qvjx Django: cache middleware may expose private responses when unrelated request cookies are present | Medium | Also affects django |
| GHSA-8cjm-8mp7-r2xf Django: UpdateCacheMiddleware may disclose cached responses due to case-sensitive Cache-Control handling | Medium | Also affects django |
| GHSA-mm6v-q8q9-pgcf Django fails to prevent reuse of a partially-initialized connection after a failed `STARTTLS` handshake | Low | Also affects django |
| GHSA-h7pc-vwp9-298g Django: signed cookies are vulnerable to salt namespace collisions | Medium | Also affects django |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor