GHSA-q238-5cxm-5c9h BIT-django-2026-15830 CVE-2026-15830 PYSEC-2026-3717
Django GeoDjango vulnerable to denial of service through deeply nested geometry collections
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 1.11%
- Chance of exploitation in the next 30 days. Higher than 66.01% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-674 Uncontrolled Recursion
- Fix
5.2.17- Upgrade django to this version or later
Description
An issue was discovered in Django 5.2 before 5.2.17 and 6.0 before 6.0.8.
GeoDjango's django.contrib.gis.geos.GEOSGeometry is subject to a potential denial-of-service when parsing deeply nested GEOMETRYCOLLECTION objects supplied as well-known text (WKT), well-known binary (WKB), or hex-encoded WKB, which triggers unbounded recursion and a segmentation fault in the underlying GEOS library. Spatial field lookups and the django.contrib.gis.forms.GeometryField form field are also affected.
Earlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected.
Django would like to thank Andrew MacPherson and kimchunbok_ for reporting this issue.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| django | < 5.2.17 |
5.2.17 |
| django | >= 6.0a1, < 6.0.8 |
6.0.8 |
| django | >= 6.1a1, < 6.1.1 |
6.1.1 |
| django | < 5.2.17>= 6.0, < 6.0.8 |
5.2.176.0.8 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
django PyPI → 5.2.17
- pip
pip install --upgrade "django>=5.2.17"- poetry
poetry add "django>=5.2.17"- uv
uv add "django>=5.2.17"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- None
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- Low
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Weakness
CWE-674: Uncontrolled Recursion
The product does not properly control the amount of recursion that takes place, consuming excessive resources, such as allocated memory or the program stack.
How to prevent it
- Implementation: Ensure that an end condition will be reached under all logic conditions. The end condition may include checking against the depth of recursion and exiting with an error if the recursion goes too deep. The complexity of the end condition contributes to the effectiveness of this action.
- Implementation: Increase the stack size.
References
Advisories
Fixes and patches
Packages
Other links
- github.com/django/django/commit/1eafa1a80f1363283f89208ba4499ed54e35f085
- github.com/django/django/commit/4353dfb56f8ba3a6fccc4bdd7f2ef2fbee3aa638
- github.com/django/django/commit/62ef9d40cf4ea75f16518436b44b8ab2515340df
- github.com/django/django/commit/6af5da31775417c610dbf9c3f1b5b8333d42daf6
- github.com/django/django/commit/75d401a1491e04a907ed745c128836d51c982c0f
- github.com/django/django/commit/9e4a3f186b6b07b483bfd9195ea06734663fcd06
- github.com/django/django/commit/ba80833fa656dd09660b97c4429331067db1b080
- github.com/django/django/commit/d2e59b77fe18de318a8272c2a7bbc798d84d1d0d
- docs.djangoproject.com/en/dev/releases/security
- github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2026-3717.yaml
- groups.google.com/g/django-announce
- djangoproject.com/weblog/2026/aug/04/security-releases
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-wvqv-fj8w-qmhm Django GeoDjango spatial lookups allow file writes and outbound requests through GDAL raster parsing | High | Also affects django |
| GHSA-8qcx-xf44-272x Django: DomainNameValidator permits newline characters that may enable HTTP header injection | Medium | Also affects django |
| GHSA-crhf-3pfg-w68w Django: GDALRaster may over-read heap memory when constructed from bytes | Medium | Also affects django |
| GHSA-3h9f-r86x-qvjx Django: cache middleware may expose private responses when unrelated request cookies are present | Medium | Also affects django |
| GHSA-8cjm-8mp7-r2xf Django: UpdateCacheMiddleware may disclose cached responses due to case-sensitive Cache-Control handling | Medium | Also affects django |
| GHSA-mm6v-q8q9-pgcf Django fails to prevent reuse of a partially-initialized connection after a failed `STARTTLS` handshake | Low | Also affects django |
| GHSA-h7pc-vwp9-298g Django: signed cookies are vulnerable to salt namespace collisions | Medium | Also affects django |
| GHSA-923m-gv2p-w5qp Django: has_vary_header may expose cached responses when Vary values contain whitespace | Medium | Also affects django |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor