Skip to content

GHSA-q9p4-hw9m-fj2v CVE-2024-32971

Apollo Router vulnerable to Critical Regression In Query Plan Cache

Critical crates.io
Severity
9.0 / 10
Critical · CVSS 3.1
Exploit chance (EPSS)
0.73%
Chance of exploitation in the next 30 days. Higher than 54.17% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-440 Expected Behavior Violation
Fix
1.45.1
Upgrade apollo-router to this version or later

Description

Impact

Any instance of Apollo Router 1.44.0 or 1.45.0 that is using Distributed Query Plan Caching is impacted. These versions were released on 2024-04-12 and 2024-04-22 respectively.

The affected versions of Apollo Router contain a bug that could lead to unexpected operations being executed, which can result in unintended data or effects. This only affects Router instances configured to use distributed query plan caching. Router versions other than the ones listed above, and all Router deployments that are not using distributed query plan caching, are unaffected by this defect.

If you are using the affected versions, you can check your router’s configuration YAML to verify if you are impacted:

supergraph:
  query_planning:
    cache:
      # Look for this config below
      redis:
        urls: ["redis://..."]

A full reference on the Distributed Query Plan Caching feature is available here.

Impact detail

The root cause of this defect is a bug in Apollo Router’s cache retrieval logic: When this defect is present and distributed query planning caching is enabled, asking the Router to execute an operation (whether it is a query, a mutation, or a subscription) may result in an unexpected variation of that operation being executed or the generation of unexpected errors.

The issue stems from inadvertently executing a modified version of a previously executed operation, whose query plan is stored in the underlying cache (specifically, Redis). Depending on the type of the operation, the result may vary. For a query, results may be fetched that don’t match what was requested (e.g., rather than running fetchUsers(type: ENTERPRISE) the Router may run fetchUsers(type: TRIAL). For a mutation, this may result in incorrect mutations being sent to underlying subgraph servers (e.g., rather than sending deleteUser(id: 10) to a subgraph, the Router may run deleteUser(id: 12).

Patches

Apollo Router 1.45.1

If you are using distributed query plan caching, please either upgrade to version 1.45.1 or above or downgrade to version 1.43.2 of the Apollo Router. We do not recommend Apollo Router versions 1.44.0 or 1.45.0 for use and have withdrawn these releases. If you use impacted versions in production, we recommend that you migrate away immediately by redeploying to an unaffected Router version. For non-production use cases, we recommend you migrate at your earliest convenience.

Workarounds

If you cannot upgrade or downgrade, you can disable distributed query plan caching by removing the supergraph.query_planning.cache.redis.urls configuration. Please note that when distributed query plan caching is disabled, each Router instance will maintain its own in-memory query plan cache. This may increase resource utilization for each Router instance and could increase cold-start times as each Router instance builds its query plan cache.

References

Apollo Router 1.45.1 Release Notes

Affected versions

crates.io

PackageVulnerableFixed in
apollo-router
>= 1.44.0, < 1.45.1
1.45.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

apollo-router crates.io → 1.45.1

cargo
cargo update -p apollo-router --precise 1.45.1

Severity breakdown

CVSS 3.1 9.0

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

Attack vector
Network
Attack complexity
High
Privileges required
None
User interaction
None
Scope
Changed
Confidentiality
High
Integrity
High
Availability
High

Weakness

CWE-440: Expected Behavior Violation

A feature, API, or function does not perform according to its specification.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-hff2-gcpx-8f4p
Apollo Router Core: Browser Bug Enables Bypass of XS-Search Prevention via Read-Only Cross-Site Request Forgery
Medium Also affects apollo-router
GHSA-x33c-7c2v-mrj9
Apollo Router Affected by an Access Control Bypass on Polymorphic Types
High Also affects apollo-router
GHSA-g8jh-vg5j-4h3f
Apollo Router Improperly Enforces Renamed Access Control Directives
High Also affects apollo-router
GHSA-3j43-9v8v-cp3f
Apollo Router Query Validation Vulnerable to Excessive Resource Consumption via Named Fragment Processing
High Also affects apollo-router
GHSA-84m6-5m72-45fp
Apollo Router Operation Limits Vulnerable to Bypass via Integer Overflow
High Also affects apollo-router
GHSA-75m2-jhh5-j5g2
Apollo Router Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion
High Also affects apollo-router
GHSA-94hh-jmq8-2fgp
Apollo Router Query Planner Vulnerable to Excessive Resource Consumption via Optimization Bypass
High Also affects apollo-router
GHSA-x6xq-whh3-gg32
Apollo Router Coprocessors may cause Denial-of-Service when handling request bodies
High Also affects apollo-router
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor