GHSA-jwhv-rgqc-fqj5 CVE-2007-5380
Session fixation vulnerability in Rails
- Severity
- Medium
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 3.58%
- Chance of exploitation in the next 30 days. Higher than 89.39% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-384 Session Fixation
- Fix
1.2.4- Upgrade rails to this version or later
Description
Session fixation vulnerability in Rails before 1.2.4, as used for Ruby on Rails, allows remote attackers to hijack web sessions via unspecified vectors related to "URL-based sessions."
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| rails | < 1.2.4 |
1.2.4 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
rails RubyGems → 1.2.4
- bundler
bundle update rails # Gemfile: gem "rails", ">= 1.2.4"
Weakness
CWE-384: Session Fixation
Authenticating a user, or otherwise establishing a new user session, without invalidating any existing session identifier gives an attacker the opportunity to steal authenticated sessions.
How to prevent it
- Architecture and Design: Invalidate any existing session identifiers prior to authorizing a new user session.
- Architecture and Design: For platforms such as ASP that do not generate new values for sessionid cookies, utilize a secondary cookie. In this approach, set a secondary cookie on the user's browser to a random value and set a session variable to the same value. If the session variable and the cookie value ever don't match, invalidate the session, and force the user to log on again.
- Operation: Use an application firewall that can detect attacks against this weakness. It can be beneficial in cases in which the code cannot be fixed (because it is controlled by a third party), as an emergency prevention measure while more comprehensive software assurance measures are applied, or to provide defense in depth [REF-1481].
References
Advisories
Packages
Other links
- github.com/rubysec/ruby-advisory-db/blob/master/gems/rails/CVE-2007-5380.yml
- bugs.gentoo.org/show_bug.cgi
- docs.info.apple.com/article.html
- lists.apple.com/archives/security-announce/2007/Dec/msg00002.html
- secunia.com/advisories/27657
- secunia.com/advisories/27965
- secunia.com/advisories/28136
- security.gentoo.org/glsa/glsa-200711-17.xml
- weblog.rubyonrails.org/2007/10/5/rails-1-2-4-maintenance-release
- novell.com/linux/security/advisories/2007_25_sr.html
- securityfocus.com/bid/26096
- us-cert.gov/cas/techalerts/TA07-352A.html
- vupen.com/english/advisories/2007/3508
- vupen.com/english/advisories/2007/4238
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-9822-6m93-xqf4 Rails has possible XSS Vulnerability in Action Controller | Medium | Also affects rails |
| GHSA-rxq3-gm4p-5fj4 rails vulnerable to improper authentication | Critical | Also affects rails |
| GHSA-rvpq-5xqx-pfpp Ruby on Rails vulnerable to code injection | High | Also affects rails |
| GHSA-jmgf-p46x-982h rails is vulnerable to CRLF injection | Medium | Also affects rails |
| GHSA-p4c6-77gc-694x session fixation protection mechanism in cgi_process.rb in Rails | Medium | Also affects rails |
| GHSA-fjfg-q662-gm6j Moderate severity vulnerability that affects rails | Medium | Also affects rails |
| GHSA-gm25-fpmr-43fj Moderate severity vulnerability that affects rails | Medium | Also affects rails |
| GHSA-9wrq-xvmp-xjc8 Rails Denial of Service vulnerability | High | Also affects rails |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor