GHSA-fjfg-q662-gm6j CVE-2007-5379
Moderate severity vulnerability that affects rails
- Severity
- Medium
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 3.97%
- Chance of exploitation in the next 30 days. Higher than 90.46% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
1.2.4- Upgrade rails to this version or later
Description
Rails before 1.2.4, as used for Ruby on Rails, allows remote attackers and ActiveResource servers to determine the existence of arbitrary files and read arbitrary XML files via the Hash.from_xml (Hash#from_xml) method, which uses XmlSimple (XML::Simple) unsafely, as demonstrated by reading passwords from the Pidgin (Gaim) .purple/accounts.xml file.
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| rails | < 1.2.4 |
1.2.4 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
rails RubyGems → 1.2.4
- bundler
bundle update rails # Gemfile: gem "rails", ">= 1.2.4"
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
- github.com/rubysec/ruby-advisory-db/blob/master/gems/rails/CVE-2007-5379.yml
- rubyonrails.org/2007/10/5/rails-1-2-4-maintenance-release
- web.archive.org/web/20090602000500/http://dev.rubyonrails.org/ticket/8453
- bugs.gentoo.org/show_bug.cgi
- docs.info.apple.com/article.html
- lists.apple.com/archives/security-announce/2007/Dec/msg00002.html
- security.gentoo.org/glsa/glsa-200711-17.xml
- us-cert.gov/cas/techalerts/TA07-352A.html
- vupen.com/english/advisories/2007/3508
- vupen.com/english/advisories/2007/4238
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-9822-6m93-xqf4 Rails has possible XSS Vulnerability in Action Controller | Medium | Also affects rails |
| GHSA-rxq3-gm4p-5fj4 rails vulnerable to improper authentication | Critical | Also affects rails |
| GHSA-rvpq-5xqx-pfpp Ruby on Rails vulnerable to code injection | High | Also affects rails |
| GHSA-jmgf-p46x-982h rails is vulnerable to CRLF injection | Medium | Also affects rails |
| GHSA-p4c6-77gc-694x session fixation protection mechanism in cgi_process.rb in Rails | Medium | Also affects rails |
| GHSA-jwhv-rgqc-fqj5 Session fixation vulnerability in Rails | Medium | Also affects rails |
| GHSA-gm25-fpmr-43fj Moderate severity vulnerability that affects rails | Medium | Also affects rails |
| GHSA-9wrq-xvmp-xjc8 Rails Denial of Service vulnerability | High | Also affects rails |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor