GHSA-jm79-9pm4-vrw9 CVE-2023-34090
Decidim vulnerable to sensitive data disclosure
- Severity
- 7.5 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 1.26%
- Chance of exploitation in the next 30 days. Higher than 69.61% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
- Available
- 2 packages have a fixed version
Description
Note: added the actual report as a comment.
Summary
Decidim, a platform for digital citizen participation, uses a third-party library named Ransack for filtering certain database collections (e.g., public meetings). By default, this library allows filtering on all data attributes and associations. This allows an unauthenticated remote attacker to exfiltrate non-public data from the underlying database of a Decidim instance (e.g., exfiltrating data from the user table).
Impact
This issue may lead to Sensitive Data Disclosure.
Patches
The problem was patched in v0.27.3.
Workarounds
Disable or unpublish all meetings components from your application.
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| decidim | >= 0.27.0, < 0.27.3 |
0.27.3 |
| decidim-meetings | >= 0.27.0, < 0.27.3 |
0.27.3 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
decidim RubyGems → 0.27.3
- bundler
bundle update decidim # Gemfile: gem "decidim", ">= 0.27.3"
decidim-meetings RubyGems → 0.27.3
- bundler
bundle update decidim-meetings # Gemfile: gem "decidim-meetings", ">= 0.27.3"
Severity breakdown
CVSS 3.1 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
- github.com/decidim/decidim/security/advisories/GHSA-jm79-9pm4-vrw9
- github.com/decidim/decidim/security/advisories/GHSA-jm79-9pm4-vrw9
- github.com/decidim/decidim/releases/tag/v0.27.3
- github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-meetings/CVE-2023-…
- github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim/CVE-2023-34090.yml
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-r3v7-5x4c-c69q Decidim: JWT-backed authentication can be replayed across organizations | High | Also affects decidim |
| GHSA-3cx6-j9j4-54mp Decidim's private data exports can lead to data leaks | Medium | Also affects decidim |
| GHSA-cc4g-m3g7-xmw8 Decidim has a cross-site scripting vulnerability in the version control page | High | Also affects decidim |
| GHSA-vvqw-fqwx-mqmm Decidim::Admin vulnerable to cross-site scripting (XSS) in the admin panel with QuillJS WYSWYG editor | Medium | Also affects decidim |
| GHSA-7cx8-44pc-xv3q Decidim cross-site scripting (XSS) in the pagination | High | Also affects decidim |
| GHSA-qcj6-vxwx-4rqv Decidim vulnerable to data disclosure through the embed feature | Medium | Also affects decidim |
| GHSA-9w99-78rj-hmxq Cross-site scripting (XSS) in the dynamic file uploads | Medium | Also affects decidim |
| GHSA-w3q8-m492-4pwp Possibility to circumvent the invitation token expiry period | High | Also affects decidim |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor