Skip to content

GHSA-f7qq-56ww-84cr CVE-2025-10157 PYSEC-2025-153

Picklescan is Vulnerable to Unsafe Globals Check Bypass through Subclass Imports

High PyPI
Severity
0.0 / 10
High · CVSS 4.0
Exploit chance (EPSS)
0.79%
Chance of exploitation in the next 30 days. Higher than 56.26% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-693 Protection Mechanism Failure
Fix
0.0.31
Upgrade picklescan to this version or later

Description

Summary

The vulnerability allows malicious actors to bypass PickleScan's unsafe globals check, leading to potential arbitrary code execution. The issue stems from PickleScan's strict check for full module names against its list of unsafe globals. By using subclasses of dangerous imports instead of the exact module names, attackers can circumvent the check and inject malicious payloads.

PoC

  1. Download a model that uses the asyncio package:

wget https://huggingface.co/iluem/linux_pkl/resolve/main/asyncio_asyncio_unix_events___UnixSubprocessTransport__start.pkl

  1. Check with PickleScan: picklescan -p asyncio_asyncio_unix_events___UnixSubprocessTransport__start.pkl -g

Expected Result:

PickleScan should identify all asyncio import as dangerous and flag the pickle file as malicious as asyncio is in _unsafe_globals dictionary.

Actual Result: Screenshot 2025-06-29 at 14 13 38

PickleScan marked the import as Suspicious, failing to identify it as a dangerous import.

Impact

Severity: High Affected Users: Any organization, like HuggingFace, or individual using PickleScan to analyze PyTorch models or other files distributed as ZIP archives for malicious pickle content. Impact Details: Attackers can craft malicious PyTorch models containing embedded pickle payloads, package them into ZIP archives, and bypass the PickleScan check by using subclasses of dangerous imports. This could lead to arbitrary code execution on the user's system when these malicious files are processed or loaded.

Recommendations:

Replace: https://github.com/mmaitre314/picklescan/blob/2a8383cfeb4158567f9770d86597300c9e508d0f/src/picklescan/scanner.py#L309C9-L309C54

unsafe_filter = _unsafe_globals.get(g.module)

by:

      matched_key = None
        if imported_global.module:
            for key_in_globals in unsafe_globals.keys():
                # Check if imported_global.module starts with the key_in_globals AND
                # (it's the first match OR this key is more specific than the previous match)
                # AND imported_global.module is exactly the key or imported_global.module is key + '.' + something
                if imported_global.module.startswith(key_in_globals):
                    if (imported_global.module == key_in_globals or # Exact match
                            (len(imported_global.module) > len(key_in_globals) and imported_global.module[len(key_in_globals)] == '.')): # Submodule match
                        if matched_key is None or len(key_in_globals) > len(matched_key):
                            matched_key = key_in_globals

        if matched_key:
            unsafe_filter = unsafe_globals[matched_key]

Affected versions

PyPI

PackageVulnerableFixed in
picklescan
< 0.0.31
0.0.31

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

picklescan PyPI → 0.0.31

pip
pip install --upgrade "picklescan>=0.0.31"
poetry
poetry add "picklescan>=0.0.31"
uv
uv add "picklescan>=0.0.31"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
None
Privileges required
None
User interaction
None
Confidentiality (vulnerable system)
High
Integrity (vulnerable system)
High
Availability (vulnerable system)
High
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 8.3

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
Required
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
Low

Weakness

CWE-693: Protection Mechanism Failure

The product does not use or incorrectly uses a protection mechanism that provides sufficient defense against directed attacks against the product.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-g38g-8gr9-h9xp
PickleScan has multiple stdlib modules with direct RCE not in blocklist
Critical Also affects picklescan
GHSA-vvpj-8cmc-gx39
PickleScan's pkgutil.resolve_name has a universal blocklist bypass
Critical Also affects picklescan
GHSA-7wx9-6375-f5wh
PickleScan's profile.run blocklist mismatch allows exec() bypass
Critical Also affects picklescan
GHSA-97f8-7cmv-76j2
Picklescan (scan_pytorch) Bypass via dynamic eval MAGIC_NUMBER
High Also affects picklescan
GHSA-m7j5-r2p5-c39r
picklescan vulnerable to arbitrary file create using logging.FileHandler
Medium Also affects picklescan
GHSA-9m3x-qqw2-h32h
picklescan missing detection by simple obfuscation of a `builtins.eval` call
Critical Also affects picklescan
GHSA-9726-w42j-3qjr
picklescan has Arbitrary file read using `io.FileIO`
High Also affects picklescan
GHSA-46h3-79wf-xr6c
Picklescan is vulnerable to RCE via missing detection when calling built-in python _operator.attrgetter
High Also affects picklescan
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor