GHSA-crp2-qrr5-8pq7 CVE-2022-23648 GO-2022-0344
containerd CRI plugin: Insecure handling of image volumes
- Severity
- 7.5 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 27.39%
- Chance of exploitation in the next 30 days. Higher than 98.06% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
1.4.13- Upgrade github.com/containerd/containerd to this version or later
Description
Impact
A bug was found in containerd where containers launched through containerd’s CRI implementation with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation.
Patches
This bug has been fixed in containerd 1.6.1, 1.5.10 and 1.4.13. Users should update to these versions to resolve the issue.
Workarounds
Ensure that only trusted images are used.
Credits
The containerd project would like to thank Felix Wilhelm of Google Project Zero for responsibly disclosing this issue in accordance with the containerd security policy.
For more information
If you have any questions or comments about this advisory:
- Open an issue in containerd
- Email us at security@containerd.io
Affected versions
Go
| Package | Vulnerable | Fixed in |
|---|---|---|
| github.com/containerd/containerd | < 1.4.13 |
1.4.13 |
| github.com/containerd/containerd | >= 1.5.0, < 1.5.10 |
1.5.10 |
| github.com/containerd/containerd | >= 1.6.0, < 1.6.1 |
1.6.1 |
| github.com/containerd/containerd | < 1.4.13>= 1.5.0, < 1.5.10>= 1.6.0, < 1.6.1 |
1.4.131.5.101.6.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
github.com/containerd/containerd Go → 1.4.13
- go
go get github.com/containerd/containerd@v1.4.13 && go mod tidy
Severity breakdown
CVSS 3.1 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
- github.com/containerd/containerd/security/advisories/GHSA-crp2-qrr5-8pq7
- github.com/containerd/containerd/commit/10f428dac7cec44c864e1b830a4623af27a9fc70
- github.com/containerd/containerd/releases/tag/v1.4.13
- github.com/containerd/containerd/releases/tag/v1.5.10
- github.com/containerd/containerd/releases/tag/v1.6.1
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AUD…
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HFT…
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OCC…
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/AUDQU…
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HFTS2…
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/OCCAR…
- security.gentoo.org/glsa/202401-31
- debian.org/security/2022/dsa-5091
- packetstormsecurity.com/files/166421/containerd-Image-Volume-Insecure-Handling.html
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-rp3h-jf77-q9p4 containerd: Unpack DoS via repeated opaque whiteouts | Medium | Also affects github.com/containerd/containerd |
| GO-2026-6791 containerd CRI plugin: Checkpoint restore bypasses destination security context | High | Also affects github.com/containerd/containerd |
| GHSA-pg57-6jwg-q645 Containerd has image-pull DoS via crafted OCI index graph amplification | Medium | Also affects github.com/containerd/containerd |
| GHSA-7jxh-36q5-gcqv containerd: CRI ExecSync Goroutine Leak Leads to Node-Level Denial of Service | Medium | Also affects github.com/containerd/containerd |
| GO-2026-5064 containerd CRI checkpoint restore CDI annotation smuggling | Critical | Also affects github.com/containerd/containerd |
| GO-2026-5622 Arbitrary host CRI log file read via symlink following in CRI checkpoint restore | Medium | Also affects github.com/containerd/containerd |
| GHSA-xhf5-7wjv-pqxp containerd CRI — image-config `LABEL` flows to restart-monitor `binary://` logger: host-root command execution from an image pull | High | Also affects github.com/containerd/containerd |
| GO-2026-5338 containerd: CRI checkpoint import allows local image tag poisoning | Critical | Also affects github.com/containerd/containerd |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor