Skip to content

GHSA-ch5v-fhg8-7gv9 CVE-2018-12423 PYSEC-2026-844

Matrix Synapse Authorization Error

High PyPI
Severity
7.5 / 10
High · CVSS 3.0
Exploit chance (EPSS)
1.81%
Chance of exploitation in the next 30 days. Higher than 78.63% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
—
Not classified
Fix
0.31.2
Upgrade matrix-synapse to this version or later

Description

In Synapse before 0.31.2, unauthorised users can hijack rooms when there is no m.room.power_levels event in force.

Affected versions

PyPI

PackageVulnerableFixed in
matrix-synapse
< 0.31.2
0.31.2

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

matrix-synapse PyPI → 0.31.2

pip
pip install --upgrade "matrix-synapse>=0.31.2"
poetry
poetry add "matrix-synapse>=0.31.2"
uv
uv add "matrix-synapse>=0.31.2"

Severity breakdown

CVSS 3.0 7.5

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
High
Availability
None

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-6qf2-7x63-mm6v
Synapse pagination Denial of Service
Low Also affects matrix-synapse
GHSA-8q93-326v-3m7g
Synapse CPU starvation (Denial of Service)
Medium Also affects matrix-synapse
GHSA-fh66-fcv5-jjfr
Synapse's invalid device keys degrade federation functionality
Medium Also affects matrix-synapse
GHSA-v56r-hwv5-mxg6
Synapse vulnerable to federation denial of service via malformed events
High Also affects matrix-synapse
GHSA-56w4-5538-8v8h
Synapse Matrix has a partial room state leak via Sliding Sync
Medium Also affects matrix-synapse
GHSA-vp6v-whfm-rv3g
Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders
Critical Also affects matrix-synapse
GHSA-f3r3-h2mq-hx2h
Synapse allows a a malformed invite to break the invitee's `/sync`
Medium Also affects matrix-synapse
GHSA-rfq8-j7rh-8hf2
Synapse allows unsupported content types to lead to memory exhaustion
High Also affects matrix-synapse
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor