GHSA-6xwf-xvf3-v459 BIT-airflow-2024-26280 CVE-2024-26280 PYSEC-2024-42
Apache Airflow: Incorrect Default Permissions in audit logs for Ops and Viewers users
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 1.86%
- Chance of exploitation in the next 30 days. Higher than 79.19% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-276 Incorrect Default Permissions
- Fix
2.8.2- Upgrade apache-airflow to this version or later
Description
Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated Ops and Viewers users to view all information on audit logs, including dag names and usernames they were not permitted to view. With 2.8.2 and newer, Ops and Viewer users do not have audit log permission by default, they need to be explicitly granted permissions to see the logs. Only admin users have audit log permission by default.
Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| apache-airflow | < 2.8.2 |
2.8.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
apache-airflow PyPI → 2.8.2
- pip
pip install --upgrade "apache-airflow>=2.8.2"- poetry
poetry add "apache-airflow>=2.8.2"- uv
uv add "apache-airflow>=2.8.2"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- High
- User interaction
- None
- Confidentiality (vulnerable system)
- Low
- Integrity (vulnerable system)
- Low
- Availability (vulnerable system)
- Low
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 4.7
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- High
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Weakness
CWE-276: Incorrect Default Permissions
During installation, installed file permissions are set to allow anyone to modify those files.
How to prevent it
- Architecture and Design, Operation: The architecture needs to access and modification attributes for files to only those users who actually require those actions.
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
- github.com/apache/airflow/pull/37501
- github.com/apache/airflow/commit/1a96407cd2d76616c1137de288f092d4f3b097fa
- github.com/apache/airflow/commit/7f10998c17ab9d725bc8671deb4c12d672bfba99
- github.com/apache/airflow/commit/8324c87e05741e5a673c43b315619a3788bacc2e
- github.com/apache/airflow/commit/8463ee4f25114a6c5fb2408d6026afe94bdf106d
- github.com/apache/airflow/commit/f2ea8a3e1753012bfe0d529c9c8be66cf55ca28f
- github.com/apache/airflow/commit/f4b9cc74976b7df1acbc3c63471b5751b3e2c40c
- github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2024-42.…
- lists.apache.org/thread/knskxxxml95091rsnpxkpo1jjp8rj0fh
- openwall.com/lists/oss-security/2024/03/01/1
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| CVE-2020-13927 Authentication bypass in Apache Airflow | Critical Known exploited | Also affects apache-airflow |
| CVE-2020-11978 Remote code execution (RCE) in Apache Airflow | High Known exploited | Also affects apache-airflow |
| PYSEC-2026-3990 Apache Airflow: the Core API logout endpoint revokes only a session token presented as the _token cookie. | Critical | Also affects apache-airflow |
| PYSEC-2026-3989 When a request to the Airflow core API carries both a session cookie and an explicit `Authorization: Bearer` token, Airflow resolves the caller from the cookie… | Medium | Also affects apache-airflow |
| PYSEC-2026-3988 Apache Airflow's `/assets/events` API returned asset events for every Dag in the deployment, with no filter restricting them to the Dags the caller is… | Medium | Also affects apache-airflow |
| GHSA-5247-m8w9-2v4m Apache Airflow missing team context permits cross-team Dag actions and XCom reads | Medium | Also affects apache-airflow |
| GHSA-f3c2-j7g8-vpp8 Apache Airflow Task SDK fails to mask list-shaped JSON Variables | Medium | Also affects apache-airflow |
| GHSA-cjv4-7hp2-2x9h Apache Airflow bulk endpoints log Variable and Connection secrets in cleartext | Medium | Also affects apache-airflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor