GHSA-636j-7x7r-gvw2 CVE-2022-1155
Old sessions not blocked by login enable function in Snipe-IT
- Severity
- 7.4 / 10
- High · CVSS 3.0
- Exploit chance (EPSS)
- 0.99%
- Chance of exploitation in the next 30 days. Higher than 62.58% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-613 Insufficient Session Expiration
- Fix
6.0.0-RC-6- Upgrade snipe/snipe-it to this version or later
Description
Snipe-IT is a FOSS project for asset management in IT Operations. In Snipe-IT versions 5.4.1 and 6.0.0-RC-5 and prior, active sessions are not revoked when a user account is disabled, allowing that user to still access information that they should no longer be able to. Workarounds include using the KillAllSessions console command, clearing the contents of the storage/framework/sessions directory, or changing the cookie name, but all of those options logout ALL users, which could be kind of annoying. This issue is fixed in versions 6.0.0-RC-6 and 5.4.2.
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| snipe/snipe-it | >= 6.0.0-RC-1, < 6.0.0-RC-6 |
6.0.0-RC-6 |
| snipe/snipe-it | < 5.4.2 |
5.4.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
snipe/snipe-it Packagist → 6.0.0-RC-6
- composer
composer require snipe/snipe-it:^6.0.0-RC-6
Severity breakdown
CVSS 3.0 7.4
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Changed
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Weakness
CWE-613: Insufficient Session Expiration
According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization."
How to prevent it
- Implementation: Set sessions/credentials expiration date.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-396x-xmvh-p563 Snipe-IT: Stored XSS via Inline XML Rendering in the Uploaded Files API | Medium | Also affects snipe/snipe-it |
| GHSA-p9h3-gvpq-5539 Snipe-IT: Stored XSS via Custom Field name in asset-list column headers | High | Also affects snipe/snipe-it |
| GHSA-hxcx-9h4f-42xx Snipe-IT: 2FA bypass via the API token flow | High | Also affects snipe/snipe-it |
| GHSA-c8qc-wf67-342w Snipe-IT: Stored DOM XSS via table selected-count IDs | Medium | Also affects snipe/snipe-it |
| GHSA-r9r3-g9fp-3q4q Snipe-IT: Maintenance Record Disclosure via Missing Authorization on GET | Medium | Also affects snipe/snipe-it |
| GHSA-3hgv-jr5j-cg9x Snipe-IT: Chained Information Disclosure and IDOR Leads to Full EULA File Takeover | Medium | Also affects snipe/snipe-it |
| GHSA-c6w2-j4wq-mvwg Snipe-IT: Tenant Isolation Bypass in FMCS Floater Mode | High | Also affects snipe/snipe-it |
| GHSA-35cr-9hqq-p2mg Snipe-IT: Cross-company deletion of pending checkout acceptances via unscoped report endpoint | Medium | Also affects snipe/snipe-it |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor