GHSA-5g2w-9f8g-g5q7 BIT-airflow-2026-24098 CVE-2026-24098 PYSEC-2026-12
Apache Airflow UI Exposes DAG Import Errors to Unauthorized Authenticated Users
- Severity
- 6.5 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.83%
- Chance of exploitation in the next 30 days. Higher than 57.48% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
3.1.7- Upgrade apache-airflow to this version or later
Description
Impact
Exposure of Sensitive Information:
An information disclosure vulnerability exists in the Apache Airflow UI that allows authenticated users to view Import Errors for DAGs they are not authorized to access.
In affected versions, the Import Errors view does not correctly filter errors based on granular DAG permissions. This means a user with access to only DAG_A can view import errors generated by DAG_B, DAG_C, or system-level DAGs. These error logs often contain file paths, code snippets, or stack traces that reveal the internal structure and logic of restricted DAGs.
Patches
Users should upgrade to Apache Airflow 3.1.7 or later. This version strictly enforces DAG-level permissions on the Import Errors view.
Workarounds
There are no known workarounds other than upgrading.
Resources
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| apache-airflow | < 3.1.7 |
3.1.7 |
| apache-airflow | >= 3.0.0, < 3.1.7 |
3.1.7 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
apache-airflow PyPI → 3.1.7
- pip
pip install --upgrade "apache-airflow>=3.1.7"- poetry
poetry add "apache-airflow>=3.1.7"- uv
uv add "apache-airflow>=3.1.7"
Severity breakdown
CVSS 3.1 6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| CVE-2020-13927 Authentication bypass in Apache Airflow | Critical Known exploited | Also affects apache-airflow |
| CVE-2020-11978 Remote code execution (RCE) in Apache Airflow | High Known exploited | Also affects apache-airflow |
| PYSEC-2026-3990 Apache Airflow: the Core API logout endpoint revokes only a session token presented as the _token cookie. | Critical | Also affects apache-airflow |
| PYSEC-2026-3989 When a request to the Airflow core API carries both a session cookie and an explicit `Authorization: Bearer` token, Airflow resolves the caller from the cookie… | Medium | Also affects apache-airflow |
| PYSEC-2026-3988 Apache Airflow's `/assets/events` API returned asset events for every Dag in the deployment, with no filter restricting them to the Dags the caller is… | Medium | Also affects apache-airflow |
| GHSA-5247-m8w9-2v4m Apache Airflow missing team context permits cross-team Dag actions and XCom reads | Medium | Also affects apache-airflow |
| GHSA-f3c2-j7g8-vpp8 Apache Airflow Task SDK fails to mask list-shaped JSON Variables | Medium | Also affects apache-airflow |
| GHSA-cjv4-7hp2-2x9h Apache Airflow bulk endpoints log Variable and Connection secrets in cleartext | Medium | Also affects apache-airflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor