GHSA-5f35-pq34-c87q BIT-airflow-2023-39441 CVE-2023-39441 PYSEC-2026-1130 PYSEC-2026-2368 PYSEC-2026-2371
Apache Airflow missing Certificate Validation
- Severity
- 5.9 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.80%
- Chance of exploitation in the next 30 days. Higher than 56.74% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-295 Improper Certificate Validation
- Fix
- Available
- 3 packages have a fixed version
Description
Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability.
The default SSL context with SSL library did not check a server's X.509 certificate. Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position.
Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| apache-airflow | < 2.7.0 |
2.7.0 |
| apache-airflow-providers-imap | < 3.3.0 |
3.3.0 |
| apache-airflow-providers-smtp | < 1.3.0 |
1.3.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
apache-airflow PyPI → 2.7.0
- pip
pip install --upgrade "apache-airflow>=2.7.0"- poetry
poetry add "apache-airflow>=2.7.0"- uv
uv add "apache-airflow>=2.7.0"
apache-airflow-providers-imap PyPI → 3.3.0
- pip
pip install --upgrade "apache-airflow-providers-imap>=3.3.0"- poetry
poetry add "apache-airflow-providers-imap>=3.3.0"- uv
uv add "apache-airflow-providers-imap>=3.3.0"
apache-airflow-providers-smtp PyPI → 1.3.0
- pip
pip install --upgrade "apache-airflow-providers-smtp>=1.3.0"- poetry
poetry add "apache-airflow-providers-smtp>=1.3.0"- uv
uv add "apache-airflow-providers-smtp>=1.3.0"
Severity breakdown
CVSS 3.1 5.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-295: Improper Certificate Validation
The product does not validate, or incorrectly validates, a certificate.
How to prevent it
- Architecture and Design, Implementation: Certificates should be carefully managed and checked to assure that data are encrypted with the intended owner's public key.
- Implementation: If certificate pinning is being used, ensure that all relevant properties of the certificate are fully validated before the certificate is pinned, including the hostname.
References
Advisories
Packages
Other links
- github.com/apache/airflow/pull/33070
- github.com/apache/airflow/pull/33075
- github.com/apache/airflow/pull/33108
- github.com/apache/airflow/commit/38fc9cd823feafd8ec61d5d5c7eddb9e9162f755
- github.com/apache/airflow/commit/3bd8f020e8b7bdeb7f618bdbdfb3557f117b29d3
- github.com/apache/airflow/commit/dbacacbd4d476da757de148a4e747924c34fd7fe
- lists.apache.org/thread/xzp4wgjg2b1o6ylk2595df8bstlbo1lb
- openwall.com/lists/oss-security/2023/08/23/2
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| CVE-2020-13927 Authentication bypass in Apache Airflow | Critical Known exploited | Also affects apache-airflow |
| CVE-2020-11978 Remote code execution (RCE) in Apache Airflow | High Known exploited | Also affects apache-airflow |
| PYSEC-2026-3990 Apache Airflow: the Core API logout endpoint revokes only a session token presented as the _token cookie. | Critical | Also affects apache-airflow |
| PYSEC-2026-3989 When a request to the Airflow core API carries both a session cookie and an explicit `Authorization: Bearer` token, Airflow resolves the caller from the cookie… | Medium | Also affects apache-airflow |
| PYSEC-2026-3988 Apache Airflow's `/assets/events` API returned asset events for every Dag in the deployment, with no filter restricting them to the Dags the caller is… | Medium | Also affects apache-airflow |
| GHSA-5247-m8w9-2v4m Apache Airflow missing team context permits cross-team Dag actions and XCom reads | Medium | Also affects apache-airflow |
| GHSA-f3c2-j7g8-vpp8 Apache Airflow Task SDK fails to mask list-shaped JSON Variables | Medium | Also affects apache-airflow |
| GHSA-cjv4-7hp2-2x9h Apache Airflow bulk endpoints log Variable and Connection secrets in cleartext | Medium | Also affects apache-airflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor