GHSA-4jcj-7x88-m979 CVE-2026-12773 PYSEC-2026-4067
LiteLLM: MCP Proxy Has Improper Authentication
- Severity
- 0.0 / 10
- Critical · CVSS 4.0
- Exploit chance (EPSS)
- 1.02%
- Chance of exploitation in the next 30 days. Higher than 63.33% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Fix
1.84.0- Upgrade litellm to this version or later
Description
A weakness has been identified in BerriAI litellm up to 1.59.8. Affected is the function UserAPIKeyAuth of the file litellm/proxy/_experimental/mcp_server/auth/user_api_key_auth_mcp.py of the component MCP Proxy. Executing a manipulation can lead to improper authentication. The attack may be launched remotely. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| litellm | < 1.84.0 |
1.84.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
litellm PyPI → 1.84.0
- pip
pip install --upgrade "litellm>=1.84.0"- poetry
poetry add "litellm>=1.84.0"- uv
uv add "litellm>=1.84.0"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- None
- User interaction
- None
- Confidentiality (vulnerable system)
- Low
- Integrity (vulnerable system)
- Low
- Availability (vulnerable system)
- Low
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
- Exploit maturity
- Proof of concept
CVSS 3.1 7.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Weakness
CWE-287: Improper Authentication
When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
How to prevent it
- Architecture and Design: Use an authentication framework or library such as the OWASP ESAPI Authentication feature.
CWE-303: Incorrect Implementation of Authentication Algorithm
The requirements for the product dictate the use of an established authentication algorithm, but the implementation of the algorithm is incorrect.
References
Advisories
Packages
Other links
- github.com/BerriAI/litellm/commit/73869f0faf7d11ee21adcb5f91b8c33a340b6c2c
- access.redhat.com/security/cve/CVE-2026-12773
- bugzilla.redhat.com/show_bug.cgi
- gist.github.com/YLChen-007/3cfaad10a69d7a15e4d4d458cb53309e
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-12773.json
- vuldb.com/cve/CVE-2026-12773
- vuldb.com/submit/811282
- vuldb.com/vuln/372515
- vuldb.com/vuln/372515/cti
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-7488-6r32-c95q LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback | High Known exploited | Also affects litellm |
| GHSA-v4p8-mg3p-g94g LiteLLM: Authenticated command execution via MCP stdio test endpoints | High Known exploited | Also affects litellm |
| GHSA-r75f-5x8p-qvmc LiteLLM has SQL Injection in Proxy API key verification | Critical Known exploited | Also affects litellm |
| GHSA-g5ff-637f-6q2m LiteLLM: internal_user_viewer arbitrary local file read via `vertex_ai_credentials` | High | Also affects litellm |
| GHSA-hhww-mrg2-969h LiteLLM vulnerable to reflected XSS in /sso/debug/callback | Medium | Also affects litellm |
| GHSA-7hp6-4w63-5g45 LiteLLM: Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key | Critical | Also affects litellm |
| GHSA-hx8v-g79f-8w5f LiteLLM Proxy has server-side request forgery via the `user_config` request parameter | Medium | Also affects litellm |
| GHSA-3cv6-jpf6-8222 LiteLLM: Authenticated SSRF and provider-credential exfiltration via unvalidated request-body routing parameters | Medium | Also affects litellm |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor