GHSA-3x4c-pq33-4w3q CVE-2021-39164 PYSEC-2021-425
Improper authorisation of members discloses room membership to non-members
- Severity
- 3.1 / 10
- Low · CVSS 3.1
- Exploit chance (EPSS)
- 1.45%
- Chance of exploitation in the next 30 days. Higher than 73.38% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
1.41.1- Upgrade matrix-synapse to this version or later
Description
Impact
Unauthorised users can access the membership (list of members, with their display names) of a room if they know the ID of the room. The vulnerability is limited to rooms with shared history visibility. Furthermore, the unauthorised user must be using an account on a vulnerable homeserver that is in the room.
Patches
Server administrators should upgrade to 1.41.1 or later.
Workarounds
Administrators of servers that use a reverse proxy could, with potentially unacceptable loss of functionality, block the following endpoints:
/_matrix/client/r0/rooms/{room_id}/memberswithatquery parameter/_matrix/client/unstable/rooms/{room_id}/memberswithatquery parameter
References
n/a
For more information
If you have any questions or comments about this advisory, e-mail us at security@matrix.org.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| matrix-synapse | < 1.41.1 |
1.41.1 |
| matrix-synapse | < 1.41.1 |
1.41.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
matrix-synapse PyPI → 1.41.1
- pip
pip install --upgrade "matrix-synapse>=1.41.1"- poetry
poetry add "matrix-synapse>=1.41.1"- uv
uv add "matrix-synapse>=1.41.1"
Severity breakdown
CVSS 3.1 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
- github.com/matrix-org/synapse/security/advisories/GHSA-3x4c-pq33-4w3q
- github.com/matrix-org/synapse/commit/cb35df940a
- github.com/matrix-org/synapse/releases/tag/v1.41.1
- github.com/pypa/advisory-database/tree/main/vulns/matrix-synapse/PYSEC-2021-425…
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2VHDE…
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PXT7I…
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PXT7I…
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2VHDE…
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-6qf2-7x63-mm6v Synapse pagination Denial of Service | Low | Also affects matrix-synapse |
| GHSA-8q93-326v-3m7g Synapse CPU starvation (Denial of Service) | Medium | Also affects matrix-synapse |
| GHSA-fh66-fcv5-jjfr Synapse's invalid device keys degrade federation functionality | Medium | Also affects matrix-synapse |
| GHSA-v56r-hwv5-mxg6 Synapse vulnerable to federation denial of service via malformed events | High | Also affects matrix-synapse |
| GHSA-56w4-5538-8v8h Synapse Matrix has a partial room state leak via Sliding Sync | Medium | Also affects matrix-synapse |
| GHSA-vp6v-whfm-rv3g Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders | Critical | Also affects matrix-synapse |
| GHSA-f3r3-h2mq-hx2h Synapse allows a a malformed invite to break the invitee's `/sync` | Medium | Also affects matrix-synapse |
| GHSA-rfq8-j7rh-8hf2 Synapse allows unsupported content types to lead to memory exhaustion | High | Also affects matrix-synapse |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor