GHSA-37gx-jqx9-fwmg CVE-2023-49250
Improper Certificate Validation in Apache DolphinScheduler
- Severity
- 7.3 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 0.70%
- Chance of exploitation in the next 30 days. Higher than 53.34% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-295 Improper Certificate Validation
- Fix
3.2.1- Upgrade org.apache.dolphinscheduler:dolphinscheduler to this version or later
Description
Because the HttpUtils class did not verify certificates, an attacker that could perform a Man-in-the-Middle (MITM) attack on outgoing https connections could impersonate the server.
This issue affects Apache DolphinScheduler: before 3.2.1.
Users are recommended to upgrade to version 3.2.1, which fixes the issue.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.dolphinscheduler:dolphinscheduler | < 3.2.1 |
3.2.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.dolphinscheduler:dolphinscheduler Maven → 3.2.1
- maven
<dependency><groupId>org.apache.dolphinscheduler</groupId><artifactId>dolphinscheduler</artifactId><version>3.2.1</version></dependency>- gradle
implementation("org.apache.dolphinscheduler:dolphinscheduler:3.2.1")
Severity breakdown
CVSS 3.1 7.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Weakness
CWE-295: Improper Certificate Validation
The product does not validate, or incorrectly validates, a certificate.
How to prevent it
- Architecture and Design, Implementation: Certificates should be carefully managed and checked to assure that data are encrypted with the intended owner's public key.
- Implementation: If certificate pinning is being used, ensure that all relevant properties of the certificate are fully validated before the certificate is pinned, including the hostname.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-72mv-wwvm-vgp5 Apache DolphinScheduler has an Incorrect Authorization Vulnerability | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-f786-9c63-8xr8 Apache DolphinScheduler RPC module has a Deserialization of Untrusted Data vulnerability | Medium | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-3cjc-vhfm-ffp2 Apache DolphinScheduler vulnerable to sensitive information disclosure | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-rrpj-r8h7-rm7r Apache DolphinScheduler Incorrect Default Permissions Vulnerability | Critical | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-3vcp-r62v-xpvg Apache DolphinScheduler vulnerable to Alert Script Attack | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-4vv4-crw4-8pcw Apache DolphinScheduler: Resource File Read And Write Vulnerability | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-m9q4-p56m-mc6q Apache DolphinScheduler: RCE by arbitrary js execution | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
| GHSA-ff2w-wm48-jhqj Arbitrary File Read Vulnerability in Apache Dolphinscheduler | High | Also affects org.apache.dolphinscheduler:dolphinscheduler |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor