GHSA-2qx8-589j-gcpx CVE-2011-1950 PYSEC-2011-16 PYSEC-2026-2888
Plone and plone.app.users allow remote authenticated users to modify the properties of arbitrary accounts
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 2.35%
- Chance of exploitation in the next 30 days. Higher than 83.70% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- —
- Not classified
- Fix
- Available
- 2 packages have a fixed version
Description
plone.app.users in Plone 4.0 and 4.1 allows remote authenticated users to modify the properties of arbitrary accounts via unspecified vectors, as exploited in the wild in June 2011.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| plone | >= 4.0.1, < 4.0.6 |
4.0.6 |
| plone | >= 4.1.0, < 4.1.1 |
4.1.1 |
| plone | < 4.1.1 |
4.1.1 |
| plone-app-users | >= 1.0a1, < 1.0.5 |
1.0.5 |
| plone-app-users | >= 1.1b1, < 1.1.1 |
1.1.1 |
| plone-app-users | >= 1.0a1, < 1.0.5>= 1.1b1, < 1.1.1 |
1.0.51.1.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
plone PyPI → 4.0.6
- pip
pip install --upgrade "plone>=4.0.6"- poetry
poetry add "plone>=4.0.6"- uv
uv add "plone>=4.0.6"
plone-app-users PyPI → 1.0.5
- pip
pip install --upgrade "plone-app-users>=1.0.5"- poetry
poetry add "plone-app-users>=1.0.5"- uv
uv add "plone-app-users>=1.0.5"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:A
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- High
- Availability (vulnerable system)
- None
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
- Exploit maturity
- Attacked
CVSS 3.1 6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- High
- Availability
- None
References
Advisories
Packages
Other links
- exchange.xforce.ibmcloud.com/vulnerabilities/67695
- github.com/pypa/advisory-database/tree/main/vulns/plone/PYSEC-2011-16.yaml
- plone.org/products/plone/security/advisories/CVE-2011-1950
- securityfocus.com/bid/48005
- osvdb.org/72729
- securityreason.com/securityalert/8269
- securityfocus.com/archive/1/518155/100/0/threaded
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-xg5p-8wg5-rhxm Phone information disclosure vulnerability | High | Also affects plone |
| GHSA-5xfx-55x4-j223 Cross-Frame Scripting vulnerability has been found on Plone CMS | High | Also affects plone |
| GHSA-47p5-p3jw-w78w Server-Side Request Forgery in Plone CMS | High | Also affects plone |
| GHSA-cvwc-g7fw-7xrj Plone XSS Vulnerability | Medium | Also affects plone |
| GHSA-pwgm-jvqv-6v8p Plone anonymous access to sub-objects in CMFEditions where KwAsAttributes classes were publishable | High | Also affects plone |
| GHSA-46f9-f8jm-mw2x Plone Cross-site Scripting vulnerability in the LiveSearch module | Medium | Also affects plone |
| GHSA-hjp5-hv33-q58g Plone credentials stored in session cookie | Medium | Also affects plone |
| GHSA-593c-j348-f3gv Plone Improper Session Management | High | Also affects plone |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor