Skip to content

yui (npm)

Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 3.10.13 or later clears every advisory below that has a fix.

Upgrade commands
npm
npm install yui@3.10.13
yarn
yarn add yui@3.10.13
pnpm
pnpm add yui@3.10.13

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-9ww8-j8j2-3788
YUI Cross-site Scripting (XSS) vulnerability
Medium
EPSS 1.19%
>= 3.2.0, <= 3.9.1
No fix yet
GHSA-64r3-582j-frqm
YUI Cross-site Scripting (XSS) vulnerability
Medium
EPSS 1.19%
>= 3.2.0, <= 3.9.1
No fix yet
GHSA-x5hj-47vv-53p8
YUI Cross-site Scripting (XSS) vulnerability
Medium
EPSS 1.49%
>= 3.0.0, < 3.10.11
3.10.11
GHSA-x5hj-47vv-53p8
YUI Cross-site Scripting (XSS) vulnerability
Medium
EPSS 1.49%
>= 3.10.12, < 3.10.13
3.10.13
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor