Skip to content

yaml (npm)

YAML parser and serialiser for JavaScript

Advisories
5
Latest version
2.9.1
Released Sep 11, 2026
License
ISC
OpenSSF Scorecard
8.0 / 10

How to fix

Upgrading to 2.8.3 or later clears every advisory below that has a fix.

Upgrade commands
npm
npm install yaml@2.9.1
yarn
yarn add yaml@2.9.1
pnpm
pnpm add yaml@2.9.1

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-48c2-rrv3-qjmp
yaml is vulnerable to Stack Overflow via deeply nested YAML collections
Medium
EPSS 0.49%
>= 2.0.0, < 2.8.3
2.8.3
GHSA-48c2-rrv3-qjmp
yaml is vulnerable to Stack Overflow via deeply nested YAML collections
Medium
EPSS 0.49%
>= 1.0.0, < 1.10.3
1.10.3
GHSA-48c2-rrv3-qjmp
yaml is vulnerable to Stack Overflow via deeply nested YAML collections
Medium
EPSS 0.49%
>= 2.0.0, < 2.8.3
2.8.3
GHSA-48c2-rrv3-qjmp
yaml is vulnerable to Stack Overflow via deeply nested YAML collections
Medium
EPSS 0.49%
>= 1.0.0, < 1.10.3
1.10.3
GHSA-f9xv-q969-pqx4
Uncaught Exception in yaml
High
EPSS 1.09%
>= 2.0.0-5, < 2.2.2
2.2.2

Source: git+https://github.com/eemeli/yaml.git

Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor